summaryrefslogtreecommitdiff
path: root/packages/nonworking/python/python-sword_1.5.10.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-14 01:41:57 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-14 01:41:57 +0000
commit69a255fd229218b722d82ad1314eb83cc2cb83bd (patch)
tree937e28f554a0f007ba8ac3c610ccd27b7b6093f6 /packages/nonworking/python/python-sword_1.5.10.bb
parentff220131472264146b9712efec29aa85596e8321 (diff)
[python-]sword: move to nonworking
Diffstat (limited to 'packages/nonworking/python/python-sword_1.5.10.bb')
-rw-r--r--packages/nonworking/python/python-sword_1.5.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/nonworking/python/python-sword_1.5.10.bb b/packages/nonworking/python/python-sword_1.5.10.bb
new file mode 100644
index 0000000000..4769a8814f
--- /dev/null
+++ b/packages/nonworking/python/python-sword_1.5.10.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ touch ltmain.sh
+ ./autogen.sh
+}
+
+do_compile() {
+ oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+ cd ${S}/python
+ distutils_do_install
+}