summaryrefslogtreecommitdiff
path: root/packages/nis/nis.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/nis/nis.inc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/nis/nis.inc')
-rw-r--r--packages/nis/nis.inc34
1 files changed, 0 insertions, 34 deletions
diff --git a/packages/nis/nis.inc b/packages/nis/nis.inc
deleted file mode 100644
index 90f7ff50a0..0000000000
--- a/packages/nis/nis.inc
+++ /dev/null
@@ -1,34 +0,0 @@
-# This include file contains global definitions for the
-# various NIS packages.
-#
-# These packages will only function correctly with glibc -
-# the rpcsvc functionality is not present in uclibc
-DESCRIPTION ?= "NIS Server and Tools"
-HOMEPAGE ?= "http://www.linux-nis.org/nis/"
-SECTION ?= "console/network"
-PRIORITY ?= "optional"
-LICENSE ?= "GPLv2"
-
-# Override these *after* the include file if necessary!
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/net/NIS/${P}.tar.bz2"
-
-inherit autotools gettext
-
-# install is broken because src/Makefile heroically adds '-s'
-# to the install flags - passing -s to the build /usr/bin/install!
-# install-strip gets it right but installs ypbind -m <default>,
-# not -m 555. In an OE build this is not, so far as I can see,
-# a security problem (and this fix to the build problem is *much*
-# easier and more maintainable.)
-do_install() {
- oe_runmake 'DESTDIR=${D}' install-strip
-}
-
-# An attempt to build on uclibc will fail, causing annoyance,
-# so force the package to be skipped here (this will cause a
-# 'nothing provides' error)
-python () {
- os = bb.data.getVar("TARGET_OS", d, 1)
- if os == "linux-uclibc":
- raise bb.parse.SkipPackage("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
-}