summaryrefslogtreecommitdiff
path: root/packages/netkit-telnet/netkit-telnet_0.17.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-23 23:27:26 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-23 23:27:26 +0100
commit3c8bf3a7484c1645de5c4cfa5c502895c97aef25 (patch)
treeaf20c960ce0355a2e6f55d124bf72622ac7cf6cb /packages/netkit-telnet/netkit-telnet_0.17.bb
parentd68a6d8a5b3a7c35d6cfdcf35e9f74f88f2202eb (diff)
parent11b836fb6d3502b46482b937f9bd607b06438de8 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/netkit-telnet/netkit-telnet_0.17.bb')
-rw-r--r--packages/netkit-telnet/netkit-telnet_0.17.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/netkit-telnet/netkit-telnet_0.17.bb b/packages/netkit-telnet/netkit-telnet_0.17.bb
new file mode 100644
index 0000000000..f5ac239039
--- /dev/null
+++ b/packages/netkit-telnet/netkit-telnet_0.17.bb
@@ -0,0 +1,27 @@
+SECTION = "base"
+DESCRIPTION = "netkit-telnet includes the telnet daemon and client."
+DEPENDS = "ncurses"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz \
+ file://netkit-telnet-debian_0.17-36.diff;patch=1 \
+ file://cross-compile.patch;patch=1 "
+
+do_configure () {
+ ./configure --prefix=${prefix}
+
+ # Inject our ldflags into the config... it is not horning them otherwise
+ echo "LDFLAGS=${LDFLAGS}" > MCONFIG
+}
+
+
+do_compile () {
+ oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 telnet/telnet ${D}${bindir}/telnet
+}
+