summaryrefslogtreecommitdiff
path: root/packages/mythtv/mythtv_0.20.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-25 17:48:24 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-25 17:48:24 +0000
commit7a4d5b91f95ab60a68440d55e623a80a03c63bd8 (patch)
tree5ab52f6a6b4401c8b0951d65643b1e15988e5226 /packages/mythtv/mythtv_0.20.bb
parent0600591677d74c93ddc2bb2ef51b633ae0c36b21 (diff)
mythtv: unified, need testing
Diffstat (limited to 'packages/mythtv/mythtv_0.20.bb')
-rw-r--r--packages/mythtv/mythtv_0.20.bb36
1 files changed, 5 insertions, 31 deletions
diff --git a/packages/mythtv/mythtv_0.20.bb b/packages/mythtv/mythtv_0.20.bb
index ab9060de94..c9e2fdc431 100644
--- a/packages/mythtv/mythtv_0.20.bb
+++ b/packages/mythtv/mythtv_0.20.bb
@@ -1,22 +1,14 @@
-DESCRIPTION = "A full featured personal video recorder system."
-HOMEPAGE = "http://www.mythtv.org"
-LICENSE = "GPL"
-SECTION = "x11/multimedia"
-DEPENDS = "libxinerama lame libxv libxxf86vm libxvmc lirc qt-x11-free openchrome"
+require mythtv.inc
+
+DEPENDS += "openchrome"
PR = "r0"
-SRC_URI = "http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2 \
- file://configure.patch;patch=1 \
- file://libmyth-libdir.patch;patch=1"
+SRC_URI += "file://configure.patch;patch=1 \
+ file://libmyth-libdir.patch;patch=1"
# Seen on the mythtv web page:
# http://www.mythtv.org/mc/fix-mythweb-in-0.20.diff;patch=1
-inherit qmake qt3x11
-
-# there is a -march=586 somewhere in the source tree
-COMPATIBLE_HOST = 'i.86.*-linux'
-
QMAKE_PROFILES = "mythtv.pro"
mythlibs = "mythavutil mythavcodec mythavformat myth mythtv mythui mythfreemheg mythupnp mythlivemedia"
@@ -47,20 +39,6 @@ python __anonymous () {
bb.data.setVar("PACKAGES", packages, d)
}
-
-def mythtv_arch(d):
- import bb, re
- arch = bb.data.getVar('TARGET_ARCH', d, 1)
- if re.match("^i.86$", arch):
- arch = "x86"
- elif arch == "x86_64":
- arch = "x86"
- elif arch == "arm":
- arch = "armv4l"
- return arch
-
-MYTHTV_ARCH := "${@mythtv_arch(d)}"
-
do_configure_prepend() {
# it's not autotools anyway, so we call ./configure directly
find . -name "Makefile"|xargs rm -f
@@ -81,10 +59,6 @@ do_configure_prepend() {
mv settings.pro.new settings.pro
}
-do_install() {
- oe_runmake INSTALL_ROOT=${D} install
-}
-
python populate_packages_prepend () {
new_packages = []