summaryrefslogtreecommitdiff
path: root/packages/mono/mono-native_1.2.5.1.bb
diff options
context:
space:
mode:
authorHenryk Ploetz <henryk@openmoko.org>2007-09-27 20:24:22 +0000
committerCliff Brake <cbrake@bec-systems.com>2007-09-27 20:24:22 +0000
commit0179b6da643c30c5298bf880ced8cbb4a3bd57d0 (patch)
tree630050eb455659a0afd60da29b9842f4271989f1 /packages/mono/mono-native_1.2.5.1.bb
parent64079a44f7fce4283b875dbefbf76f2970a3b21c (diff)
mono-native 1.2.5.1: fix up mono native compile and make mono depend on it
Diffstat (limited to 'packages/mono/mono-native_1.2.5.1.bb')
-rw-r--r--packages/mono/mono-native_1.2.5.1.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/packages/mono/mono-native_1.2.5.1.bb b/packages/mono/mono-native_1.2.5.1.bb
index 2670d3fb55..09223ddcab 100644
--- a/packages/mono/mono-native_1.2.5.1.bb
+++ b/packages/mono/mono-native_1.2.5.1.bb
@@ -1,10 +1,21 @@
require mono_1.2.5.inc
-PR = "r0"
+PR = "r1"
DEPENDS = "glib-2.0-native"
+SRC_URI += "file://mono-fix-libdir-path.patch;patch=1"
+
inherit native
#do_stage_prepend() {
# install -m 755 ${S}/mono/monoburg/monoburg ${STAGING_BINDIR}
#}
+do_fix_libtool_name() {
+ # inherit native will make that all native tools that are being
+ # built are prefixed with something like "i686-linux-",
+ # including libtool. Fix up some hardcoded libtool names:
+ for i in "${S}"/runtime/*-wrapper.in; do
+ sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
+ done
+}
+addtask fix_libtool_name after do_patch before do_configure