summaryrefslogtreecommitdiff
path: root/packages/midpath
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-11-26 14:45:14 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-11-26 14:45:14 +0000
commitdc55bdcac1f124990a9837f39374c753ffd86dec (patch)
tree0b9d26957bf2c51dcff6b8eea2a06adf734681aa /packages/midpath
parent0bd5a64203d0d45c4afb7f8723a553a3a830921f (diff)
parent256626d3db13a6f076f69db9ef1ab34ef1acf066 (diff)
merge of '8744f51b03fb8cbe26fbea1e61c9ca8c0cda7571'
and '9722830207e34266d2aae4fe5fba289f2f7cb711'
Diffstat (limited to 'packages/midpath')
-rw-r--r--packages/midpath/midpath-alsa_0.1.bb4
-rw-r--r--packages/midpath/midpath-cldc-sdl_0.1.bb2
-rw-r--r--packages/midpath/midpath-cldc-x11_0.1.bb2
-rw-r--r--packages/midpath/midpath-cldc_0.1.bb1
-rw-r--r--packages/midpath/midpath-gtk_0.1.bb2
-rw-r--r--packages/midpath/midpath-pulseaudio_0.1.bb39
-rw-r--r--packages/midpath/midpath-qt3x11_0.1.bb2
-rw-r--r--packages/midpath/midpath-qte_0.1.bb2
-rw-r--r--packages/midpath/midpath.inc2
9 files changed, 41 insertions, 15 deletions
diff --git a/packages/midpath/midpath-alsa_0.1.bb b/packages/midpath/midpath-alsa_0.1.bb
index 940a1ea8a2..6d580405b6 100644
--- a/packages/midpath/midpath-alsa_0.1.bb
+++ b/packages/midpath/midpath-alsa_0.1.bb
@@ -13,10 +13,6 @@ do_configure() {
do_compile() {
-mkdir -p ${S}/dist
-
-# Build native code
-
# Build the ALSA native part
cd ${S}/native/alsa
make || exit 1
diff --git a/packages/midpath/midpath-cldc-sdl_0.1.bb b/packages/midpath/midpath-cldc-sdl_0.1.bb
index d00cbfc619..65850e2f4c 100644
--- a/packages/midpath/midpath-cldc-sdl_0.1.bb
+++ b/packages/midpath/midpath-cldc-sdl_0.1.bb
@@ -13,8 +13,6 @@ do_configure() {
do_compile() {
-mkdir -p ${S}/dist
-
# Build SDLJava for CLDC
cd ${S}/external/sdljava-cldc
make JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath ${CLDC_PATH}:${GNU_CLASSPATH_PATH} -sourcepath ${S}/external/sdljava-cldc -source 1.3 -target 1.1" || exit 1
diff --git a/packages/midpath/midpath-cldc-x11_0.1.bb b/packages/midpath/midpath-cldc-x11_0.1.bb
index 30ca378436..9db0c4a686 100644
--- a/packages/midpath/midpath-cldc-x11_0.1.bb
+++ b/packages/midpath/midpath-cldc-x11_0.1.bb
@@ -12,8 +12,6 @@ do_configure() {
do_compile() {
-mkdir -p ${S}/dist
-
# Build Escher X11 library
cd ${S}/external/escher-cldc/core
make JAVAC=${JAVAC_CMD} JAVAC_FLAGS="-bootclasspath ${CLDC_PATH} -sourcepath ${S}/external/escher-cldc/core -source 1.3 -target 1.1" || exit 1
diff --git a/packages/midpath/midpath-cldc_0.1.bb b/packages/midpath/midpath-cldc_0.1.bb
index 24ffc61332..51a1314467 100644
--- a/packages/midpath/midpath-cldc_0.1.bb
+++ b/packages/midpath/midpath-cldc_0.1.bb
@@ -2,6 +2,7 @@
require midpath.inc
PROVIDES = "virtual/cldc-api-1.1"
+RPROVIDES = "virtual/cldc-api-1.1"
do_compile() {
diff --git a/packages/midpath/midpath-gtk_0.1.bb b/packages/midpath/midpath-gtk_0.1.bb
index 680b4e259d..7bf5570ef2 100644
--- a/packages/midpath/midpath-gtk_0.1.bb
+++ b/packages/midpath/midpath-gtk_0.1.bb
@@ -15,8 +15,6 @@ do_configure() {
do_compile() {
-mkdir -p ${S}/dist
-
# Build the GTK native part
cd ${S}/native/gtk
make || exit 1
diff --git a/packages/midpath/midpath-pulseaudio_0.1.bb b/packages/midpath/midpath-pulseaudio_0.1.bb
new file mode 100644
index 0000000000..6344e018a0
--- /dev/null
+++ b/packages/midpath/midpath-pulseaudio_0.1.bb
@@ -0,0 +1,39 @@
+
+require midpath_${PV}.bb
+
+DEPENDS = "pulseaudio"
+RDEPENDS = "pulseaudio"
+
+do_configure() {
+ cd ${S}/native/pulseaudio
+ sed -i -e "s|\-I/usr/include/classpath|\-I${STAGING_INCDIR}/classpath-minimal|" Makefile
+ cd ${S}/resources-embedded/com/sun/midp/configuration
+ sed -i -e "s|sound.backend:NULL|sound.backend:PulseAudio|" configuration.cfg
+}
+
+do_compile() {
+
+# Build the PulseAudio native part
+cd ${S}/native/pulseaudio
+make || exit 1
+
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ install -m 0644 ${S}/native/pulseaudio/libmidpathpulse.so ${D}${libdir}
+ install -d ${D}${datadir}/java/resources-embedded/com/sun/midp/configuration
+ install -m 0644 resources-embedded/com/sun/midp/configuration/configuration.cfg ${D}${datadir}/java/resources-embedded/com/sun/midp/configuration/
+}
+
+do_stage() {
+ :
+}
+
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${libdir}/libmidpathpulse.so \
+ ${datadir}/java/resources-embedded/com/sun/midp/configuration/configuration.cfg \
+ "
+
+CONFFILES_${PN} = "${datadir}/java/resources-embedded/com/sun/midp/configuration/configuration.cfg"
diff --git a/packages/midpath/midpath-qt3x11_0.1.bb b/packages/midpath/midpath-qt3x11_0.1.bb
index 1d44706db9..1d24012810 100644
--- a/packages/midpath/midpath-qt3x11_0.1.bb
+++ b/packages/midpath/midpath-qt3x11_0.1.bb
@@ -20,8 +20,6 @@ do_configure() {
do_compile() {
-mkdir -p ${S}/dist
-
# Build the QT native part
cd ${S}/native/qt
make || exit 1
diff --git a/packages/midpath/midpath-qte_0.1.bb b/packages/midpath/midpath-qte_0.1.bb
index e37825bf57..39b9264930 100644
--- a/packages/midpath/midpath-qte_0.1.bb
+++ b/packages/midpath/midpath-qte_0.1.bb
@@ -18,8 +18,6 @@ do_configure() {
do_compile() {
-mkdir -p ${S}/dist
-
# Build the QT native part
cd ${S}/native/qt
make || exit 1
diff --git a/packages/midpath/midpath.inc b/packages/midpath/midpath.inc
index 7f6e4f3d31..33793bffd0 100644
--- a/packages/midpath/midpath.inc
+++ b/packages/midpath/midpath.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://midpath.thenesis.org/"
LICENSE = "GPL"
PRIORITY = "optional"
SECTION = "interpreters"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://downloads.sourceforge.net/midpath/midpath-${PV}.tar.gz"