summaryrefslogtreecommitdiff
path: root/packages/meta
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2006-09-08 12:52:43 +0000
committerMartin Dietze <di@fh-wedel.de>2006-09-08 12:52:43 +0000
commit30596c3e0a0216faaaa5b1ffaa4bd0e2c816eb21 (patch)
tree41173d7708d23aba6ffb9ba20a8ffc6b40146d99 /packages/meta
parentabf168554971b3e714dd2ee2bbebf18ab91121e9 (diff)
nylon: updated images and nylon specific packages from 4G trunk
* updated list of supported packages in nylon-feed * new image nylon-image-extended aiming to put nylon-feed into one image (for debugging) * new versions of nylon-scripts, nylon-statistics, simple-firewall
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/nylon-feed.bb128
-rw-r--r--packages/meta/nylon-feed.inc68
2 files changed, 104 insertions, 92 deletions
diff --git a/packages/meta/nylon-feed.bb b/packages/meta/nylon-feed.bb
index f5b803f58e..40faab8056 100644
--- a/packages/meta/nylon-feed.bb
+++ b/packages/meta/nylon-feed.bb
@@ -1,99 +1,43 @@
-DEPENDS = " \
-base-files \
-bash \
-bridge-utils \
-busybox \
-chillispot \
-dash \
-db3 \
-ddclient \
-dhcp-forwarder \
-dhcp \
-dnsmasq \
-expat \
-gdb \
-glib-2.0 \
-glibc \
-gmp \
-gnupg \
-hostap-modules \
-hostap-utils \
-hostap-daemon \
-linux-hotplug \
-htb-init \
-ifplugd \
-initscripts \
-iperf \
-ipkg \
-iproute2 \
-iptables \
-virtual/kernel \
-kismet \
-less \
-libcgicc \
-libmail-sendmail-perl \
-libnetserver-generic-perl \
-libpcap \
-lsof \
-lzo \
-madwifi-modules \
-maradns \
-mc \
-mobilemesh \
-modutils \
-mtd-utils \
-mtr \
-nano \
-ncurses \
-netbase \
-netperf \
-net-snmp \
-ntp \
-nylon-scripts \
-nylon-statistics \
-olsrd \
-openssh \
-openssl \
-openvpn \
-openswan \
-pciutils \
-pcre \
-perl \
-pmacct \
-ppp \
-ppp-dsl \
-rp-pppoe \
-rrdtool \
-prism2-firmware-update \
-prism54-module \
-prism54-firmware \
-shorewall \
-stunnel \
-sysvinit \
-tcpdump \
-tinc \
-timezones \
-usbutils \
-vtun \
-wireless-tools \
-wlan-ng-modules \
-yamonenv \
-zlib \
-"
+LICENSE = MIT
-# TODO:
-# ksymoops / binutils
-# strace: SYS_read?
-# gdb-cross: install paths, sdk?
-# screen: sgttyb?
-# nocat?
-# pptp
-# meshroaming
+include nylon-feed.inc
+DEPENDS = "${NYLON_FEED} \
+ db3 \
+ dhcp \
+ dhcp-forwarder \
+ expat \
+ glib-2.0 \
+ glibc \
+ gmp \
+ hotplug \
+ iproute2 \
+ libcgicc \
+ libedit \
+ libmail-sendmail-perl \
+ libnetserver-generic-perl \
+ lzo \
+ make \
+ mystun-server \
+ mc \
+ net-snmp \
+ ntp \
+ openssl \
+ openswan \
+ openvpn \
+ pcre \
+ ppp-dsl \
+ rp-pppoe \
+ simple-firewall \
+ thttpd \
+ vsftpd \
+ wget \
+ wlan-ng-modules \
+ zlib \
+"
do_index() {
- ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
+ ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
}
addtask index before do_build after do_install
-LICENSE = MIT
diff --git a/packages/meta/nylon-feed.inc b/packages/meta/nylon-feed.inc
new file mode 100644
index 0000000000..f2e55dc3a6
--- /dev/null
+++ b/packages/meta/nylon-feed.inc
@@ -0,0 +1,68 @@
+NYLON_FEED = " \
+base-files \
+bash \
+binutils \
+bridge-utils \
+busybox \
+chillispot \
+dash \
+ddclient \
+dnsmasq \
+gdb \
+gnupg \
+hostap-modules \
+hostap-utils \
+hostap-daemon \
+hotplug-ng \
+htb-init \
+ifplugd \
+initscripts \
+iperf \
+ipkg \
+iptables \
+kismet \
+ksymoops \
+less \
+lsof \
+madwifi-modules \
+maradns \
+minicom \
+mobilemesh \
+modutils \
+mtd-utils \
+mtr \
+nano \
+ncurses \
+netbase \
+netperf \
+nylon-scripts \
+nylon-statistics \
+olsrd \
+openssh \
+pciutils \
+pcmcia-cs \
+perl \
+pmacct \
+ppp \
+pptp-linux \
+rrdtool \
+ser \
+shorewall \
+stunnel \
+sysvinit \
+tcl \
+tcpdump \
+tinc \
+timezones \
+usbutils \
+vtun \
+wireless-tools \
+wpa-supplicant \
+yamonenv \
+"
+
+# TODO:
+# strace: SYS_read?
+# gdb-cross: install paths, sdk?
+# screen: sgttyb?
+