summaryrefslogtreecommitdiff
path: root/packages/ltp/ltp_20070228.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-03-10 14:18:01 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-03-10 14:18:01 +0000
commit54da6877f11a0c74b4e4a55ff0bade5cf3a7c5d8 (patch)
tree430c369b6c67b7666c166aa313fccc3d519bfb33 /packages/ltp/ltp_20070228.bb
parente2152105462938dd24049d166836f0875257feab (diff)
parent1b661974e3f8f844f6ec4cdb7bb42cef9595b626 (diff)
merge of '25f6ad493ba862d73422f5468f734f72840fa6af'
and '7b2d2094f68ede9c9d5e10c5722472d35573e9b1'
Diffstat (limited to 'packages/ltp/ltp_20070228.bb')
-rw-r--r--packages/ltp/ltp_20070228.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/ltp/ltp_20070228.bb b/packages/ltp/ltp_20070228.bb
new file mode 100644
index 0000000000..400d642641
--- /dev/null
+++ b/packages/ltp/ltp_20070228.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Linux Test Project"
+HOMEPAGE = "http://ltp.sourceforge.net"
+LICENSE = "GPL"
+SECTION = "console/utils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.tgz \
+ file://cross-compile.patch;patch=1 \
+ file://runltp-path.patch;patch=1 \
+ file://ltp-run"
+
+S = "${WORKDIR}/ltp-full-${PV}"
+
+EXTRA_OEMAKE_append = " CROSS_COMPILE=${HOST_PREFIX}"
+
+do_compile(){
+ oe_runmake CROSS_COMPILE=${HOST_PREFIX}
+}
+
+do_install(){
+ export CREATE=0
+ export LTPROOT=${D}/usr/libexec/ltp/testcases
+
+ oe_runmake install
+
+ install -d ${D}/usr/libexec/ltp/testcases
+ install -d ${D}/usr/libexec/ltp/pan
+
+ #install testcases
+ #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/testcases
+ #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/
+
+ # treecopy testcases pan/pan runtest ver_linux IDcheck.sh \
+ # ${D}/usr/libexec/ltp
+ cp testcases ${D}/usr/libexec/ltp/ -rfp
+ rm ${D}/usr/libexec/ltp/ballista -rf
+ cp pan/pan ${D}/usr/libexec/ltp/pan -p
+ cp runtest ${D}/usr/libexec/ltp/ -rfp
+ cp ver_linux ${D}/usr/libexec/ltp/ -p
+ cp runltp ${D}/usr/libexec/ltp/ -p
+ cp IDcheck.sh ${D}/usr/libexec/ltp/ -p
+}
+