summaryrefslogtreecommitdiff
path: root/packages/lirc/lirc-modules_0.8.3+cvs20080713.bb
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-07-25 01:10:00 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-07-25 01:10:00 +0000
commit3caf3594fb150525211d76b8df7c504534e4c331 (patch)
tree07e6960ce15865389949aa4be0369307234268d2 /packages/lirc/lirc-modules_0.8.3+cvs20080713.bb
parent1a5fd7ec9efde8a138431e3b470b340ebea6cfe3 (diff)
parenta3e73146adce111fe67af0886a43acbf7a654bd7 (diff)
merge of 'bdbc9f1de56a38029ef1396ead1cd220bf2c07b2'
and 'f960843459326876ef399375d5affaacc45d0a46'
Diffstat (limited to 'packages/lirc/lirc-modules_0.8.3+cvs20080713.bb')
-rw-r--r--packages/lirc/lirc-modules_0.8.3+cvs20080713.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/lirc/lirc-modules_0.8.3+cvs20080713.bb b/packages/lirc/lirc-modules_0.8.3+cvs20080713.bb
new file mode 100644
index 0000000000..094c6fd380
--- /dev/null
+++ b/packages/lirc/lirc-modules_0.8.3+cvs20080713.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls. This package contains the lirc kernel modules."
+SECTION = "base"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.lirc.org"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel fakeroot-native setserial"
+PR = "r0"
+
+SRCDATE=${@bb.data.getVar('PV', d, 1)[9:]}
+
+SRC_URI = "cvs://anonymous@lirc.cvs.sourceforge.net/cvsroot/lirc;module=lirc;method=pserver;cvsdate=${SRCDATE}"
+S = "${WORKDIR}/lirc"
+
+
+inherit autotools module
+
+require lirc-config.inc
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e V=1' -C drivers"
+
+fakeroot do_install() {
+ oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
+ rm -rf ${D}/dev
+}
+
+# this is for distributions that don't use udev
+pkg_postinst_append() {
+if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi
+}
+
+FILES_${PN} = "/lib/modules"