summaryrefslogtreecommitdiff
path: root/packages/lirc/lirc-modules_0.7.0.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-02 21:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-02 21:40:10 +0000
commit5c889a3bff1539bf19b368a1739f592ef456aaef (patch)
tree5b67d2e4641df99cbbfc917cbdfb42b64e512465 /packages/lirc/lirc-modules_0.7.0.bb
parent12e598e0e41627e926fa40fef739772adb94de71 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/02 22:13:59+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/06/02 22:07:26+01:00 reciva.com!pb factor out lirc machine specifics into an .inc file. avoid feeding LDFLAGS to the kernel linker, since it doesn't like them. 2005/06/02 22:59:55+02:00 utwente.nl!koen nokia770.conf: remove arm926ejs from archs 2005/06/02 22:56:13+02:00 utwente.nl!koen tune-arm926ejs.conf: set arch to armv5te instead of arm926ejs as Phil pointed out BKrev: 429f7cbanu_8PuI52mw_rYQD7m0Dkg
Diffstat (limited to 'packages/lirc/lirc-modules_0.7.0.bb')
-rw-r--r--packages/lirc/lirc-modules_0.7.0.bb10
1 files changed, 3 insertions, 7 deletions
diff --git a/packages/lirc/lirc-modules_0.7.0.bb b/packages/lirc/lirc-modules_0.7.0.bb
index 7e63c561fc..99b0fabd31 100644
--- a/packages/lirc/lirc-modules_0.7.0.bb
+++ b/packages/lirc/lirc-modules_0.7.0.bb
@@ -12,15 +12,11 @@ S = "${WORKDIR}/lirc-${PV}"
inherit autotools module-base
-EXTRA_OECONF = "--with-kerneldir=${STAGING_KERNEL_DIR}"
-EXTRA_OECONF_append_epia = " --with-driver=serial"
-EXTRA_OECONF_append_collie = " --with-driver=sa1100 --without-x"
-EXTRA_OECONF_append_h3600 = " --with-driver=sa1100 --without-x"
-EXTRA_OECONF_append_beagle = " --with-driver=sa1100 --without-x"
-EXTRA_OECONF_append_simpad = " --with-driver=sa1100 --without-x"
+include lirc-config.inc
do_compile() {
- cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}"
+ # ${KERNEL_LD} doesn't understand the LDFLAGS, so suppress them
+ cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" LDFLAGS=""
}
fakeroot do_install() {