summaryrefslogtreecommitdiff
path: root/packages/lirc/lirc-modules_0.6.6+cvs20040918.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/lirc/lirc-modules_0.6.6+cvs20040918.bb
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/lirc/lirc-modules_0.6.6+cvs20040918.bb')
-rw-r--r--packages/lirc/lirc-modules_0.6.6+cvs20040918.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/lirc/lirc-modules_0.6.6+cvs20040918.bb b/packages/lirc/lirc-modules_0.6.6+cvs20040918.bb
index e69de29bb2..4cd87bba34 100644
--- a/packages/lirc/lirc-modules_0.6.6+cvs20040918.bb
+++ b/packages/lirc/lirc-modules_0.6.6+cvs20040918.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "kernel"
+DEPENDS = "virtual/kernel"
+PR = "r2"
+
+S = "${WORKDIR}/lirc"
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/lirc;module=lirc;date=20040918;method=pserver \
+file://lirc_sir-sa1100.patch;patch=1"
+
+inherit autotools module-base
+
+EXTRA_OECONF = "--with-kerneldir=${STAGING_KERNEL_DIR}"
+EXTRA_OECONF_append_epia = " --with-driver=serial"
+EXTRA_OECONF_append_collie = " --with-driver=sa1100 --without-x"
+EXTRA_OECONF_append_h3600 = " --with-driver=sa1100 --without-x"
+EXTRA_OECONF_append_beagle = " --with-driver=sa1100 --without-x"
+EXTRA_OECONF_append_simpad = " --with-driver=sa1100 --without-x"
+
+export TOPDIR = "${STAGING_KERNEL_DIR}"
+
+do_compile() {
+ cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}"
+}
+
+fakeroot do_install() {
+ oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
+ rm -rf ${D}dev
+}
+
+FILES_${PN}="/lib/modules"