summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-12-17 08:09:25 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-12-17 08:09:25 +0000
commitfa0691ce542712357bdaa15a5b58e24042dce541 (patch)
treeacedea78ae490aa350ee276d37e090f32254bae5 /packages/linux
parent5206b0d92ce6a6622ec041231314d7242a35f0e8 (diff)
linux-openmoko_2.6.22.5.bb : commit the work for OM bug #910 now people
have had plenty of warning. Now kernel-image will flash new kernel in postinst. Its noisy and leaves the kernel in / for now to ease debugging of any problems people have.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openmoko.inc15
-rw-r--r--packages/linux/linux-openmoko_2.6.22.5.bb1
2 files changed, 14 insertions, 2 deletions
diff --git a/packages/linux/linux-openmoko.inc b/packages/linux/linux-openmoko.inc
index d08169999c..b659153733 100644
--- a/packages/linux/linux-openmoko.inc
+++ b/packages/linux/linux-openmoko.inc
@@ -1,5 +1,4 @@
# extra stuff we need for openmoko that is not in linux.inc
-
do_deploy_append() {
mv ${DEPLOY_DIR_IMAGE}/modules-${PV}-${PR}-${MACHINE}.tgz ${DEPLOY_DIR_IMAGE}/modules-${PV}-${PR}-${MACHINE_CLASS}.tgz
mv ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}.bin ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE_CLASS}.bin
@@ -7,3 +6,17 @@ do_deploy_append() {
ln -sf ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE_CLASS}.bin ${DEPLOY_DIR_IMAGE}/uImage-${MACHINE_CLASS}-latest.bin
}
+RDEPENDS_kernel-image += "mtd-utils"
+
+pkg_postinst_kernel-image () {
+if test "x$D" != "x"; then
+ exit 1
+else
+ echo "Upgrading Kernel in Flash"
+ echo "DO NOT stop this process"
+
+ ${bindir}/flash_eraseall ${MTD_KERNEL_PARTITION}
+ ${bindir}/nandwrite -p ${MTD_KERNEL_PARTITION} /${KERNEL_IMAGEDEST}/${KERNEL_IMAGETYPE}-${KERNEL_VERSION}
+fi
+}
+
diff --git a/packages/linux/linux-openmoko_2.6.22.5.bb b/packages/linux/linux-openmoko_2.6.22.5.bb
index c623504c73..d1b3c5ef1e 100644
--- a/packages/linux/linux-openmoko_2.6.22.5.bb
+++ b/packages/linux/linux-openmoko_2.6.22.5.bb
@@ -37,7 +37,6 @@ S = "${WORKDIR}/linux-${VANILLA_VERSION}"
##############################################################
# kernel image resides on a seperate flash partition (for now)
#
-FILES_kernel-image = ""
ALLOW_EMPTY = "1"
COMPATIBLE_HOST = "arm.*-linux"