summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>2005-10-29 09:55:05 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-29 09:55:05 +0000
commitd2487d0aa3a5337ea34beb5861c71970b5c2cbd7 (patch)
tree40a80868d4acfec7555991ed99a93c69e8c31af9 /packages/linux
parent62a35317099f208f30e10af8002da47af9cb35f6 (diff)
parent7dd3bbef6102ab099035c4dd3c6646c2f138bd58 (diff)
merge of 6b05039266ce065dabeef6f1aac0190692348b17
and 9117a5cd2698e544e72b78d2b150f2eb221b4993
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-copy-from.patch6
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch34
-rw-r--r--packages/linux/nslu2-kernel_2.6.14.bb2
3 files changed, 22 insertions, 20 deletions
diff --git a/packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-copy-from.patch b/packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-copy-from.patch
index db71342ab0..f2e65ecd8f 100644
--- a/packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-copy-from.patch
+++ b/packages/linux/nslu2-kernel/2.6.14/10-ixp4xx-copy-from.patch
@@ -12,12 +12,12 @@
#include <linux/reboot.h>
-+/* On a little-endian IXP4XX system (tested on NSLU2) contrary to the
-+ * Intel documentation LDRH/STRH appears to XOR the address with 10b.
++/* On a little-endian IXP4XX system (tested on NSLU2) an LDRH or STRH
++ * will flip the second address bit - i.e. XOR the address with 10b.
+ * This causes the cfi commands (sent to the command address, 0xAA for
+ * 16 bit flash) to fail. This is fixed here by XOR'ing the address
+ * before use with 10b. The cost of this is that the flash layout ends
-+ * up with pdp-endiannes (on an LE syste), however this is not a problem
++ * up with pdp-endiannes (on an LE system), however this is not a problem
+ * as the access code consistently only accesses half words - so the
+ * endianness is not determinable on stuff which is written and read
+ * consistently in the little endian world.
diff --git a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
index b5029752ad..7a6dfac9cb 100644
--- a/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
+++ b/packages/linux/nslu2-kernel/2.6.14/50-nslu2-arch.patch
@@ -112,9 +112,9 @@
+}
+
+subsys_initcall(nslu2_pci_init);
---- linux-2.6.13/.pc/50-nslu2-arch.patch/arch/arm/mach-ixp4xx/nslu2-power.c 2005-10-26 15:19:43.171472071 -0700
-+++ linux-2.6.13/arch/arm/mach-ixp4xx/nslu2-power.c 2005-10-26 15:23:39.646352497 -0700
-@@ -0,0 +1,92 @@
+--- linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-power.c 2005-09-06 00:17:15.000000000 -0700
++++ linux-2.6.14/arch/arm/mach-ixp4xx/nslu2-power.c 2005-10-28 15:50:43.554157030 -0700
+@@ -0,0 +1,94 @@
+/*
+ * arch/arm/mach-ixp4xx/nslu2-power.c
+ *
@@ -140,20 +140,22 @@
+
+#include <asm/mach-types.h>
+
++extern void ctrl_alt_del(void);
++
+static irqreturn_t nslu2_power_handler(int irq, void *dev_id, struct pt_regs *regs)
+{
-+ /* Signal init to do the ctrlaltdel action */
-+ kill_proc(1, SIGINT, 1);
++ /* Signal init to do the ctrlaltdel action, this will bypass init if
++ * it hasn't started and do a kernel_restart.
++ */
++ ctrl_alt_del();
+
+ return IRQ_HANDLED;
+}
+
+static irqreturn_t nslu2_reset_handler(int irq, void *dev_id, struct pt_regs *regs)
+{
-+ /* FIXME This doesn't reset the NSLU2. It powers it off.
-+ * Close enough, since reset is unreliable
++ /* This is the paper-clip reset, it shuts the machine down directly.
+ */
-+
+ machine_power_off();
+
+ return IRQ_HANDLED;
@@ -261,19 +263,19 @@
+ .name = "IXP4XX-I2C",
+ .id = 0,
+ .dev.platform_data = &nslu2_i2c_gpio_pins,
-+ .num_resources = 0
++ .num_resources = 0,
+};
+
+static struct resource nslu2_uart_resources[] = {
+ {
+ .start = IXP4XX_UART1_BASE_PHYS,
+ .end = IXP4XX_UART1_BASE_PHYS + 0x0fff,
-+ .flags = IORESOURCE_MEM
++ .flags = IORESOURCE_MEM,
+ },
+ {
+ .start = IXP4XX_UART2_BASE_PHYS,
+ .end = IXP4XX_UART2_BASE_PHYS + 0x0fff,
-+ .flags = IORESOURCE_MEM
++ .flags = IORESOURCE_MEM,
+ }
+};
+
@@ -304,18 +306,18 @@
+ .id = PLAT8250_DEV_PLATFORM,
+ .dev.platform_data = nslu2_uart_data,
+ .num_resources = 2,
-+ .resource = nslu2_uart_resources
++ .resource = nslu2_uart_resources,
+};
+
+static struct platform_device *nslu2_devices[] __initdata = {
+ &nslu2_i2c_controller,
+ &nslu2_flash,
-+ &nslu2_uart
++ &nslu2_uart,
+};
+
+static void nslu2_power_off(void)
+{
-+ /* This causes the box to drop the power and go dead. */
++ /* This causes the box to drop the power and go dead. */
+
+ /* enable the pwr cntl gpio */
+ gpio_line_config(NSLU2_PO_GPIO, IXP4XX_GPIO_OUT);
@@ -340,8 +342,8 @@
+ .io_pg_offst = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xFFFC,
+ .boot_params = 0x00000100,
+ .map_io = ixp4xx_map_io,
-+ .init_irq = ixp4xx_init_irq, /* FIXME: all irq are off here */
-+ .timer = &ixp4xx_timer,
++ .init_irq = ixp4xx_init_irq,
++ .timer = &ixp4xx_timer,
+ .init_machine = nslu2_init,
+MACHINE_END
--- linux-2.6.13/.pc/50-nslu2-arch.patch/include/asm-arm/arch-ixp4xx/hardware.h 2005-10-26 15:19:37.451112111 -0700
diff --git a/packages/linux/nslu2-kernel_2.6.14.bb b/packages/linux/nslu2-kernel_2.6.14.bb
index 21a371369e..3dd07788bf 100644
--- a/packages/linux/nslu2-kernel_2.6.14.bb
+++ b/packages/linux/nslu2-kernel_2.6.14.bb
@@ -3,7 +3,7 @@
# Increment PR_CONFIG for changes to the nslu2-kernel specific
# defconfig (do *NOT* increment anything in here for changes
# to other kernel configs!)
-PR_CONFIG = "0"
+PR_CONFIG = "1"
#
# Increment the number below (i.e. the digits after PR) when
# making changes within this file or for changes to the patches