summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-04-14 10:58:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-14 10:58:28 +0000
commitba4813236cfa8e229ddae4af68bb12b7ef9c9822 (patch)
tree5b08f5a14b0c44f5c24f721df6361c4f83cb3ab9 /packages/linux
parentdb96eaf0375c0458ff4d56f24a73d5ce8067940e (diff)
parentc178dd162c983723a604a49c87f433ac591a5f99 (diff)
merge of 7cf02eba7575b6840c1fb5d91671c51d7ce49303
and e6da98bac7d686d3e88211061aa2804f4f75c109
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/devkitidp-pxa255-kernel_2.6.11.bb8
-rw-r--r--packages/linux/gumstix_2.6.5-gnalm1-gum0.bb7
-rw-r--r--packages/linux/linux-omap-2.6_2.6.9-omap1.bb7
-rw-r--r--packages/linux/linux-omap1_2.6.12-rc2.bb8
-rw-r--r--packages/linux/linux-wrt_2.4.20.bb7
-rw-r--r--packages/linux/linux-wrt_2.4.30.bb7
-rw-r--r--packages/linux/mainstone-kernel_2.6.11.bb7
-rw-r--r--packages/linux/nslu2-kernel.inc7
-rw-r--r--packages/linux/nslu2-linksys-kernel_2.4.22.bb7
-rw-r--r--packages/linux/openzaurus-pxa27x_2.4.20-rmk2-embedix20050602.bb1
-rw-r--r--packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.inc1
-rw-r--r--packages/linux/openzaurus-sa_2.4.18-rmk7-pxa3-embedix20030509.bb1
-rw-r--r--packages/linux/poodle-kernels-2.4-embedix.bb1
-rw-r--r--packages/linux/triton-kernel_2.6.11.bb7
-rw-r--r--packages/linux/unslung-kernel_2.4.22.l2.3r63.bb7
15 files changed, 15 insertions, 68 deletions
diff --git a/packages/linux/devkitidp-pxa255-kernel_2.6.11.bb b/packages/linux/devkitidp-pxa255-kernel_2.6.11.bb
index 0b8b6ab63a..5df470af1d 100644
--- a/packages/linux/devkitidp-pxa255-kernel_2.6.11.bb
+++ b/packages/linux/devkitidp-pxa255-kernel_2.6.11.bb
@@ -12,6 +12,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.tar.bz2 \
S = "${WORKDIR}/linux-2.6.11"
COMPATIBLE_HOST = 'arm.*-linux'
+COMPATIBLE_MACHINE = "devkitidp-pxa255"
inherit kernel
inherit package
@@ -38,10 +39,3 @@ do_deploy() {
do_deploy[dirs] = "${S}"
addtask deploy before do_build after do_compile
-
-python () {
- # Don't build kernel unless we're targeting an nslu2
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'devkitidp-pxa255':
- raise bb.parse.SkipPackage("This kernel only builds for the PXA255 DevKitIDP")
-}
diff --git a/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb b/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
index c0b3bf2742..846e5f4fa2 100644
--- a/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
+++ b/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
@@ -21,9 +21,4 @@ do_configure_prepend() {
oe_runmake oldconfig
}
-python __anonymous () {
- import re
- host = bb.data.getVar('HOST_SYS', d, 1)
- if not re.match('arm.*-linux', host):
- raise bb.parse.SkipPackage("incompatible with host %s" % host)
-}
+COMPATIBLE_HOST = 'arm.*-linux'
diff --git a/packages/linux/linux-omap-2.6_2.6.9-omap1.bb b/packages/linux/linux-omap-2.6_2.6.9-omap1.bb
index 5cb4a439b1..feb9581e5c 100644
--- a/packages/linux/linux-omap-2.6_2.6.9-omap1.bb
+++ b/packages/linux/linux-omap-2.6_2.6.9-omap1.bb
@@ -10,12 +10,7 @@ S = "${WORKDIR}/linux-2.6.9"
inherit kernel
-python __anonymous () {
- import re
- host = bb.data.getVar('HOST_SYS', d, 1)
- if not re.match('arm.*-linux', host):
- raise bb.parse.SkipPackage("incompatible with host %s" % host)
-}
+COMPATIBLE_HOST = 'arm.*-linux'
KERNEL_IMAGETYPE = "uImage"
diff --git a/packages/linux/linux-omap1_2.6.12-rc2.bb b/packages/linux/linux-omap1_2.6.12-rc2.bb
index 133fe9ac2c..7ea9e16091 100644
--- a/packages/linux/linux-omap1_2.6.12-rc2.bb
+++ b/packages/linux/linux-omap1_2.6.12-rc2.bb
@@ -18,13 +18,7 @@ KERNEL_CCSUFFIX = "-3.3.4"
inherit kernel
-python __anonymous () {
- import re
- host = bb.data.getVar('HOST_SYS', d, 1)
- if not re.match('arm.*-linux', host):
- raise bb.parse.SkipPackage("incompatible with host %s" % host)
-}
-
+COMPATIBLE_HOST = 'arm.*-linux'
do_configure_prepend() {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config
diff --git a/packages/linux/linux-wrt_2.4.20.bb b/packages/linux/linux-wrt_2.4.20.bb
index 8e49ffa2c2..32361b7810 100644
--- a/packages/linux/linux-wrt_2.4.20.bb
+++ b/packages/linux/linux-wrt_2.4.20.bb
@@ -58,9 +58,4 @@ do_deploy[dirs] = "${S}"
addtask deploy before do_build after do_compile
-python () {
- # Don't build kernel unless we're targeting a wrt
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'wrt54':
- raise bb.parse.SkipPackage("Unable to build for non-WRT54 device.")
-}
+COMPATIBLE_MACHINE = "wrt54"
diff --git a/packages/linux/linux-wrt_2.4.30.bb b/packages/linux/linux-wrt_2.4.30.bb
index 0d9229c5d8..352c879d45 100644
--- a/packages/linux/linux-wrt_2.4.30.bb
+++ b/packages/linux/linux-wrt_2.4.30.bb
@@ -112,9 +112,4 @@ do_deploy[dirs] = "${S}"
addtask deploy before do_build after do_compile
-python () {
- # Don't build kernel unless we're targeting a wrt
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'wrt54':
- raise bb.parse.SkipPackage("Unable to build for non-WRT54 device.")
-}
+COMPATIBLE_MACHINE = "wrt54"
diff --git a/packages/linux/mainstone-kernel_2.6.11.bb b/packages/linux/mainstone-kernel_2.6.11.bb
index 12422c96de..0e242c2dc8 100644
--- a/packages/linux/mainstone-kernel_2.6.11.bb
+++ b/packages/linux/mainstone-kernel_2.6.11.bb
@@ -36,9 +36,4 @@ do_deploy[dirs] = "${S}"
addtask deploy before do_build after do_compile
-python () {
- # Don't build kernel unless we're targeting a mainstone
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'mainstone':
- raise bb.parse.SkipPackage("This kernel only builds for the Mainstone")
-}
+COMPATIBLE_MACHINE = "mainstone"
diff --git a/packages/linux/nslu2-kernel.inc b/packages/linux/nslu2-kernel.inc
index b4c675264a..bfae5f82d4 100644
--- a/packages/linux/nslu2-kernel.inc
+++ b/packages/linux/nslu2-kernel.inc
@@ -257,9 +257,4 @@ do_deploy() {
addtask deploy before do_build after do_compile
-python () {
- # Don't build the kernel unless we're targeting an nslu2
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'nslu2':
- raise bb.parse.SkipPackage("nslu2-kernel only builds for the Linksys NSLU2")
-}
+COMPATIBLE_MACHINE = "nslu2"
diff --git a/packages/linux/nslu2-linksys-kernel_2.4.22.bb b/packages/linux/nslu2-linksys-kernel_2.4.22.bb
index 40bceb373e..de2715d107 100644
--- a/packages/linux/nslu2-linksys-kernel_2.4.22.bb
+++ b/packages/linux/nslu2-linksys-kernel_2.4.22.bb
@@ -17,13 +17,8 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.4/linux-2.4.22.tar.bz2 \
file://defconfig"
S = "${WORKDIR}/linux-2.4.22"
-python () {
- # Don't build unless we're targeting an nslu2
- if bb.data.getVar("MACHINE", d, 1) != "nslu2":
- raise bb.parse.SkipPackage("NSLU2 kernel only builds for the Linksys NSLU2")
-}
-
COMPATIBLE_HOST = 'arm.*-linux'
+COMPATIBLE_MACHINE = "nslu2"
inherit kernel
diff --git a/packages/linux/openzaurus-pxa27x_2.4.20-rmk2-embedix20050602.bb b/packages/linux/openzaurus-pxa27x_2.4.20-rmk2-embedix20050602.bb
index d9addd968a..eae524a7ae 100644
--- a/packages/linux/openzaurus-pxa27x_2.4.20-rmk2-embedix20050602.bb
+++ b/packages/linux/openzaurus-pxa27x_2.4.20-rmk2-embedix20050602.bb
@@ -75,6 +75,7 @@ EXTRA_OEMAKE = "OPENZAURUS_RELEASE=-${DISTRO_VERSION}"
KERNEL_CCSUFFIX = "-2.95"
KERNEL_LDSUFFIX = "-2.11.2"
COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = '(akita|spitz|borzoi)'
PARALLEL_MAKE = ""
#
diff --git a/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.inc b/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.inc
index 4c8b43121d..3b0024d147 100644
--- a/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.inc
+++ b/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.inc
@@ -89,6 +89,7 @@ EXTRA_OEMAKE = " EMBEDIXRELEASE=-${DISTRO_VERSION}"
KERNEL_CCSUFFIX = "-2.95"
KERNEL_LDSUFFIX = "-2.11.2"
COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = '(c7x0|corgi|husky|shepherd|poodle|poodle255)'
PARALLEL_MAKE = ""
#
diff --git a/packages/linux/openzaurus-sa_2.4.18-rmk7-pxa3-embedix20030509.bb b/packages/linux/openzaurus-sa_2.4.18-rmk7-pxa3-embedix20030509.bb
index f600acbaed..a79d4f3a00 100644
--- a/packages/linux/openzaurus-sa_2.4.18-rmk7-pxa3-embedix20030509.bb
+++ b/packages/linux/openzaurus-sa_2.4.18-rmk7-pxa3-embedix20030509.bb
@@ -57,6 +57,7 @@ ALLOW_EMPTY = 1
KERNEL_CCSUFFIX = "-2.95"
KERNEL_LDSUFFIX = "-2.11.2"
COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "collie"
EXTRA_OEMAKE = " EMBEDIXRELEASE=-${DISTRO_VERSION}"
module_conf_usbdmonitor = "alias usbd0 usbdmonitor"
diff --git a/packages/linux/poodle-kernels-2.4-embedix.bb b/packages/linux/poodle-kernels-2.4-embedix.bb
index e21a47a908..7a714b7a12 100644
--- a/packages/linux/poodle-kernels-2.4-embedix.bb
+++ b/packages/linux/poodle-kernels-2.4-embedix.bb
@@ -1 +1,2 @@
+COMPATIBLE_MACHINE = "poodle"
DEPENDS = "poodle-kernel-2.4-embedix poodle255-kernel-2.4-embedix"
diff --git a/packages/linux/triton-kernel_2.6.11.bb b/packages/linux/triton-kernel_2.6.11.bb
index 6fc575c2b0..e42dfa2ae9 100644
--- a/packages/linux/triton-kernel_2.6.11.bb
+++ b/packages/linux/triton-kernel_2.6.11.bb
@@ -37,9 +37,4 @@ do_deploy[dirs] = "${S}"
addtask deploy before do_build after do_compile
-python () {
- # Don't build kernel unless we're targeting an triton
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'triton':
- raise bb.parse.SkipPackage("The triton kernel is only for use on triton machines")
-}
+COMPATIBLE_MACHINE = "triton"
diff --git a/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb b/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb
index 8aa07e8978..c397a90efe 100644
--- a/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb
+++ b/packages/linux/unslung-kernel_2.4.22.l2.3r63.bb
@@ -28,9 +28,4 @@ SRC_URI += "file://linux-kernel-R25_to_R29.patch;patch=1 \
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/unslung-kernel', '${FILE_DIRNAME}/nslu2-linksys-kernel-2.4.22', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-python () {
- # Don't build unslung kernel unless we're targeting an nslu2
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'nslu2':
- raise bb.parse.SkipPackage("Unslung only builds for the Linksys NSLU2")
-}
+COMPATIBLE_MACHINE = "nslu2"