summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-10-14 10:51:13 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2006-10-14 10:51:13 +0000
commitb741ba60ef1df311fc9ac4f64ac68fe94e07471f (patch)
treed8dd52a4f2ebd6f8a3251e435fda50bfb85d8f35 /packages/linux
parent66799f20695974b82f3a4d0888710cd0856dcbe2 (diff)
ixp4xx-kernel: Updates from blaster8
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/ixp4xx-kernel-svnpatch.inc7
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.18.bb6
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.19-rc2.bb22
3 files changed, 30 insertions, 5 deletions
diff --git a/packages/linux/ixp4xx-kernel-svnpatch.inc b/packages/linux/ixp4xx-kernel-svnpatch.inc
index 573888f30a..30d7eee5dd 100644
--- a/packages/linux/ixp4xx-kernel-svnpatch.inc
+++ b/packages/linux/ixp4xx-kernel-svnpatch.inc
@@ -1,12 +1,11 @@
addtask svnpatch before do_configure after do_patch
-IXP4XX_KERNEL_SVN_REPO ?= http://svn.nslu2-linux.org/svnroot/kernel/trunk
+IXP4XX_KERNEL_SVN_REPO = http://svn.nslu2-linux.org/svnroot/kernel/trunk
do_svnpatch() {
- svn co ${IXP4XX_KERNEL_SVN_REPO}/patches/${PV} --revision ${IXP4XX_KERNEL_SVN_REV} ${WORKDIR}/patches-${PV}
+ svn co ${IXP4XX_KERNEL_SVN_REPO}/patches/${IXP4XX_KERNEL_PATCH_DIR} --revision ${IXP4XX_KERNEL_SVN_REV} ${WORKDIR}/patches-${PV}
cp ${WORKDIR}/patches-${PV}/defconfig ${WORKDIR}/defconfig
rm -rf ${S}/patches
cd ${S} && ln -s ${WORKDIR}/patches-${PV} ${S}/patches
- cd ${S} && ${STAGING_BINDIR}/quilt push -av
+ cd ${S} && rm -rf .pc && ${STAGING_BINDIR}/quilt push -av
}
-
diff --git a/packages/linux/ixp4xx-kernel_2.6.18.bb b/packages/linux/ixp4xx-kernel_2.6.18.bb
index 963658f503..611ff8c65c 100644
--- a/packages/linux/ixp4xx-kernel_2.6.18.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.18.bb
@@ -6,7 +6,11 @@
# http://trac.nslu2-linux.org/kernel/
#
# The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "446"
+IXP4XX_KERNEL_SVN_REV = "473"
+#
+# The directory containing the patches to be applied is
+# specified below
+IXP4XX_KERNEL_PATCH_DIR = "2.6.18"
#
# Increment the number below (i.e. the digits after PR) when
# the changes in SVN between revisions include changes in the
diff --git a/packages/linux/ixp4xx-kernel_2.6.19-rc2.bb b/packages/linux/ixp4xx-kernel_2.6.19-rc2.bb
new file mode 100644
index 0000000000..9ed2aa748a
--- /dev/null
+++ b/packages/linux/ixp4xx-kernel_2.6.19-rc2.bb
@@ -0,0 +1,22 @@
+# Kernel for IXP4xx
+#
+# This bitbake file pulls patches and the defconfig straight
+# from the NSLU2-Linux SVN repository. Information about this
+# repository can be found at:
+# http://trac.nslu2-linux.org/kernel/
+#
+# The revision that is pulled from SVN is specified below
+IXP4XX_KERNEL_SVN_REV = "473"
+#
+# The directory containing the patches to be applied is
+# specified below
+IXP4XX_KERNEL_PATCH_DIR = "2.6.19"
+#
+# Increment the number below (i.e. the digits after PR) when
+# the changes in SVN between revisions include changes in the
+# patches applied to the kernel, rather than simply defconfig
+# changes
+PR = "r1.${IXP4XX_KERNEL_SVN_REV}"
+
+require ixp4xx-kernel.inc
+require ixp4xx-kernel-svnpatch.inc