summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-07-12 22:26:22 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-12 22:26:22 +0000
commitb406d42a43853a43c9c3de592de7f3a152e6f235 (patch)
tree4d5865fd30711849aba9e3edf64e79b77f985ff0 /packages/linux
parent738a9bde53edf9462237240a72fd8bfd867f8b2e (diff)
parent7fd2d7fc55069e967f0696e5dcd0ab8ad90fbf31 (diff)
merge of cddb2bc75922196fed2e730ac6188b75cec87184
and d09f0621b4e183654539b5e69434b52a32e26b72
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/handhelds-un-2.6_2.6.16.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/linux/handhelds-un-2.6_2.6.16.bb b/packages/linux/handhelds-un-2.6_2.6.16.bb
new file mode 100644
index 0000000000..b261d30a7e
--- /dev/null
+++ b/packages/linux/handhelds-un-2.6_2.6.16.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Handhelds HTC-PXA phones kernel based on the hh 2.6.16"
+MAINTAINER = "goxboxlive <goxboxlive@gmail.com>"
+LICENSE = "GPL"
+PR="r0"
+
+SRC_URI = "cvs -d :pserver:anoncvs@anoncvs.handhelds.org:/cvs checkout -d linux-2.6.16-hh2 linux/kernel26"
+S = "${WORKDIR}/linux-2.6.16-hh2"
+
+COMPATIBLE_HOST = "arm.*-linux"
+
+inherit kernel
+
+do_configure() {
+ cp arch/arm/configs/htcuniversal_defconfig .config || die "No default configuration for ${MACHINE} available."
+ yes '' | oe_runmake oldconfig
+}
+
+
+###############################################################
+# put into deploy directory
+#
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.bin
+ tar -cvzf ${DEPLOY_DIR_IMAGE}/modules-${KERNEL_RELEASE}-${MACHINE}.tgz -C ${D} lib
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_package after do_install