summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-11 19:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-11 19:40:07 +0000
commitb002a9cc24da07b7ef4cec4e3f2cb7741d4f4e4e (patch)
tree15ada4286c6dd4a3522082799fb9215c8a32b55e /packages/linux
parentdb997794e09c94858c0237b15f8b69848bcd0686 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/11 20:33:00+01:00 reciva.com!pb suppress PARALLEL_MAKE for pciutils 2005/06/11 20:12:19+01:00 reciva.com!pb set KERNEL_CCSUFFIX to 3.3.4 for epia, pending availability of gcc-cross-kernel 3.4.4 2005/06/11 20:08:07+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/06/11 20:05:35+01:00 reciva.com!pb remove preference for binutils_csl-arm-20050603 due to "stfpls" problem BKrev: 42ab3e17pU3U_O8qsBteBt0JRESXaA
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-epia_2.6.11.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/linux/linux-epia_2.6.11.bb b/packages/linux/linux-epia_2.6.11.bb
index e69de29bb2..1b2ee9be6d 100644
--- a/packages/linux/linux-epia_2.6.11.bb
+++ b/packages/linux/linux-epia_2.6.11.bb
@@ -0,0 +1,28 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for VIA EPiA"
+LICENSE = "GPL"
+PR = "r0"
+
+KERNEL_CCSUFFIX = "-3.3.4"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ http://hem.bredband.net/ekmlar/patch-vt1211-2.6.txt;patch=1 \
+ file://epia_defconfig"
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'i.86.*-linux'
+
+inherit kernel
+
+ARCH = "i386"
+KERNEL_IMAGETYPE = "bzImage"
+
+# Don't want kernel in rootfs
+FILES_kernel = ""
+ALLOW_EMPTY_kernel = "1"
+PACKAGES += "kernel-image"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/epia_defconfig ${S}/.config
+}