summaryrefslogtreecommitdiff
path: root/packages/linux
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-07 16:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-07 16:40:07 +0000
commit0b3f69daef9f8b3c7ad888a4d75c1782463b3331 (patch)
tree15f2f9d244019b1151aecd76e8fa923e57c5b94b /packages/linux
parent796d95e4dd0afa1dccef44c003df614ea0630b86 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/07 17:35:51+01:00 (none)!koen Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into lieve.(none):/data/build/oe/clean-tree/openembedded 2005/01/07 17:34:59+01:00 (none)!koen make faad2 buildable again by refreshing patches 2005/01/07 17:09:12+01:00 local!hrw openzaurus 2.6.10: kernel is copied to deploy/images after build BKrev: 41debb6746cDf-wGGQKF8b376XdXVw
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/openzaurus_2.6.10.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/packages/linux/openzaurus_2.6.10.bb b/packages/linux/openzaurus_2.6.10.bb
index 6e5e7cb3c7..2d2384c9c0 100644
--- a/packages/linux/openzaurus_2.6.10.bb
+++ b/packages/linux/openzaurus_2.6.10.bb
@@ -3,11 +3,12 @@ DESCRIPTION = "2.6 Linux Development Kernel for Zaurus devices."
LICENSE = "GPL"
#KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
KV = "${@bb.data.getVar('PV',d,True)}"
+PR = "r1"
-SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${KV}.tar.gz \
#SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/testing/linux-${KV}.tar.gz \
# http://www.cs.wisc.edu/~lenz/zaurus/files/patch-2.6.7-jl1.diff.gz;patch=1 \
# http://www.rpsys.net/openzaurus/${KV}/jl1/localversion.patch;patch=1 \
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-${KV}.tar.gz \
http://www.rpsys.net/openzaurus/${KV}/jl1/pxa-linking-bug.patch;patch=1 \
http://www.rpsys.net/openzaurus/${KV}/jl1/pxa-cpu.patch;patch=1 \
http://www.rpsys.net/openzaurus/${KV}/jl1/locomo_pm.patch;patch=1 \
@@ -57,7 +58,7 @@ inherit kernel
#
FILES_kernel = ""
ALLOW_EMPTY = 1
-
+
EXTRA_OEMAKE = ""
COMPATIBLE_HOST = "arm.*-linux"
@@ -104,3 +105,12 @@ do_configure() {
echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
yes '' | oe_runmake oldconfig
}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${MACHINE}-${DATETIME}.bin
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile