summaryrefslogtreecommitdiff
path: root/packages/linux/linux-rp-2.6.19+git/add-oz-release-string.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:50:04 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-18 13:50:04 +0000
commita29979e19ed76c2029cfd822951b7fde56a98a8e (patch)
tree85102cf43b72d5ce2294ab17f565183b4436729d /packages/linux/linux-rp-2.6.19+git/add-oz-release-string.patch
parent16b15891b993ca44dacd6c15ec678b2eac721548 (diff)
parent302f1878f6adacd506a24dd55fecc262a57bf61e (diff)
merge of '1d2340f5c0766711d217ca40fbfcb4cb196412ac'
and '8bee8c12a8f566036b80dc740f5215782a19eb8b'
Diffstat (limited to 'packages/linux/linux-rp-2.6.19+git/add-oz-release-string.patch')
-rw-r--r--packages/linux/linux-rp-2.6.19+git/add-oz-release-string.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/linux/linux-rp-2.6.19+git/add-oz-release-string.patch b/packages/linux/linux-rp-2.6.19+git/add-oz-release-string.patch
new file mode 100644
index 0000000000..a80a1d5528
--- /dev/null
+++ b/packages/linux/linux-rp-2.6.19+git/add-oz-release-string.patch
@@ -0,0 +1,28 @@
+---
+ Makefile | 1 +
+ init/version.c | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+Index: git/init/version.c
+===================================================================
+--- git.orig/init/version.c 2006-10-31 16:09:47.000000000 +0000
++++ git/init/version.c 2006-10-31 16:24:54.000000000 +0000
+@@ -35,5 +35,5 @@ struct uts_namespace init_uts_ns = {
+ EXPORT_SYMBOL_GPL(init_uts_ns);
+
+ const char linux_banner[] =
+- "Linux version " UTS_RELEASE " (" LINUX_COMPILE_BY "@"
++ "Linux version " UTS_RELEASE OPENZAURUS_RELEASE " (" LINUX_COMPILE_BY "@"
+ LINUX_COMPILE_HOST ") (" LINUX_COMPILER ") " UTS_VERSION "\n";
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile 2006-10-31 16:08:28.000000000 +0000
++++ git/Makefile 2006-10-31 16:27:02.000000000 +0000
+@@ -905,6 +905,7 @@ endef
+ define filechk_version.h
+ (echo \#define LINUX_VERSION_CODE $(shell \
+ expr $(VERSION) \* 65536 + $(PATCHLEVEL) \* 256 + $(SUBLEVEL)); \
++ echo \#define OPENZAURUS_RELEASE \"$(OPENZAURUS_RELEASE)\"; \
+ echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
+ endef
+