summaryrefslogtreecommitdiff
path: root/packages/linux/linux-openmoko_2.6.28+git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-08 15:15:51 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-08 15:15:51 +0100
commitc1d6da72de49968c5fdb0d117681d7b23667156b (patch)
tree475bf0ea31045e80a05369b3aea46cb941f3ae07 /packages/linux/linux-openmoko_2.6.28+git.bb
parent7009de96358579b65a2f0168ab5a864247d6304b (diff)
parent46e900cd3d6c461317051a579f1d5ae278c1dc1b (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/linux/linux-openmoko_2.6.28+git.bb')
-rw-r--r--packages/linux/linux-openmoko_2.6.28+git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/linux/linux-openmoko_2.6.28+git.bb b/packages/linux/linux-openmoko_2.6.28+git.bb
new file mode 100644
index 0000000000..a544b89f13
--- /dev/null
+++ b/packages/linux/linux-openmoko_2.6.28+git.bb
@@ -0,0 +1,26 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
+
+KERNEL_RELEASE = "2.6.28"
+KERNEL_VERSION = "${KERNEL_RELEASE}"
+
+FILESPATH = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-openmoko-${KERNEL_RELEASE}"
+
+OEV = "oe1"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://openwrt-ledtrig-netdev.patch;patch=1 \
+ file://defconfig-oe.patch \
+"
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/gta02-moredrivers-defconfig ${WORKDIR}/defconfig-oe
+ cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
+}
+