summaryrefslogtreecommitdiff
path: root/packages/linux/linux-omap2-git/beagleboard
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-05-17 09:01:45 +0000
committerKoen Kooi <koen@openembedded.org>2008-05-17 09:01:45 +0000
commitfa719019d592dd4724f1bea024131e7524d9d44e (patch)
tree0f024025185140d11f61166e8c451dcb54ce3c65 /packages/linux/linux-omap2-git/beagleboard
parent643ff88cad9612371c74c6518514b2bea9698c5b (diff)
linux-omap2 git: remove beagleboard patches that were accepted upstream, remove usbtimeout.patch, it doesn't help. Remove l2-cache.patch now that we have a saner uboot
Diffstat (limited to 'packages/linux/linux-omap2-git/beagleboard')
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/0001-board-omap3beagle-fix-merge-damage-in-RTC-code.patch36
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/0001-omap3beagle-add-driver-to-turn-on-the-TFP410-framer.patch197
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/defconfig1
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/l2-cache.patch162
-rw-r--r--packages/linux/linux-omap2-git/beagleboard/usb-timout.patch11
5 files changed, 1 insertions, 406 deletions
diff --git a/packages/linux/linux-omap2-git/beagleboard/0001-board-omap3beagle-fix-merge-damage-in-RTC-code.patch b/packages/linux/linux-omap2-git/beagleboard/0001-board-omap3beagle-fix-merge-damage-in-RTC-code.patch
deleted file mode 100644
index 55e9bf7b54..0000000000
--- a/packages/linux/linux-omap2-git/beagleboard/0001-board-omap3beagle-fix-merge-damage-in-RTC-code.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From eddf57fb9748791e021ef550d651cc72c48add5c Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@openembedded.org>
-Date: Thu, 15 May 2008 09:32:23 +0200
-Subject: [PATCH] ARM: OMAP: board-omap3beagle: fix merge-damage in RTC code
-
-This patch fixes the merge-damage in the beagleboard RTC code
-
-Signed-off-by: Koen Kooi <koen@openembedded.org>
----
- arch/arm/mach-omap2/board-omap3beagle.c | 3 +--
- 1 files changed, 1 insertions(+), 2 deletions(-)
-
-diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
-index 0c15ca0..0c0cbfc 100644
---- a/arch/arm/mach-omap2/board-omap3beagle.c
-+++ b/arch/arm/mach-omap2/board-omap3beagle.c
-@@ -76,6 +76,7 @@ static struct platform_device *omap3_beagle_devices[] __initdata = {
-
- static void __init omap3_beagle_init(void)
- {
-+ platform_add_devices(omap3_beagle_devices, ARRAY_SIZE(omap3_beagle_devices));
- omap_board_config = omap3_beagle_config;
- omap_board_config_size = ARRAY_SIZE(omap3_beagle_config);
- omap_serial_init();
-@@ -88,8 +89,6 @@ arch_initcall(omap3_beagle_i2c_init);
-
- static void __init omap3_beagle_map_io(void)
- {
-- platform_add_devices(omap3_beagle_devices,
-- ARRAY_SIZE(omap3_beagle_devices));
- omap2_set_globals_343x();
- omap2_map_common_io();
- }
---
-1.5.4.3
-
diff --git a/packages/linux/linux-omap2-git/beagleboard/0001-omap3beagle-add-driver-to-turn-on-the-TFP410-framer.patch b/packages/linux/linux-omap2-git/beagleboard/0001-omap3beagle-add-driver-to-turn-on-the-TFP410-framer.patch
deleted file mode 100644
index 5cc10b01c1..0000000000
--- a/packages/linux/linux-omap2-git/beagleboard/0001-omap3beagle-add-driver-to-turn-on-the-TFP410-framer.patch
+++ /dev/null
@@ -1,197 +0,0 @@
-From 75b8dbeed8f53ffb7edc58b2393084fe2346477e Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@openembedded.org>
-Date: Fri, 9 May 2008 20:54:00 +0200
-Subject: [PATCH] omap3beagle: add driver to turn on the TFP410 framer to get DVI output
-
-Signed-off-by: Koen Kooi <koen@openembedded.org>
----
- arch/arm/mach-omap2/board-omap3beagle.c | 11 +++
- drivers/video/omap/Makefile | 1 +
- drivers/video/omap/lcd_omap3beagle.c | 135 +++++++++++++++++++++++++++++++
- 3 files changed, 147 insertions(+), 0 deletions(-)
- create mode 100644 drivers/video/omap/lcd_omap3beagle.c
-
-diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
-index 0c0cbfc..c992cc7 100644
---- a/arch/arm/mach-omap2/board-omap3beagle.c
-+++ b/arch/arm/mach-omap2/board-omap3beagle.c
-@@ -63,12 +63,23 @@ static struct platform_device omap3_beagle_twl4030rtc_device = {
- .id = -1,
- };
-
-+static struct platform_device omap3_beagle_lcd_device = {
-+ .name = "omap3beagle_lcd",
-+ .id = -1,
-+};
-+
-+static struct omap_lcd_config omap3_beagle_lcd_config __initdata = {
-+ .ctrl_name = "internal",
-+};
-+
- static struct omap_board_config_kernel omap3_beagle_config[] __initdata = {
- { OMAP_TAG_UART, &omap3_beagle_uart_config },
- { OMAP_TAG_MMC, &omap3beagle_mmc_config },
-+ { OMAP_TAG_LCD, &omap3_beagle_lcd_config },
- };
-
- static struct platform_device *omap3_beagle_devices[] __initdata = {
-+ &omap3_beagle_lcd_device,
- #ifdef CONFIG_RTC_DRV_TWL4030
- &omap3_beagle_twl4030rtc_device,
- #endif
-diff --git a/drivers/video/omap/Makefile b/drivers/video/omap/Makefile
-index cad6a68..fe7ee5d 100644
---- a/drivers/video/omap/Makefile
-+++ b/drivers/video/omap/Makefile
-@@ -32,6 +32,7 @@ objs-y$(CONFIG_MACH_OMAP_APOLLON) += lcd_apollon.o
- objs-y$(CONFIG_MACH_OMAP_2430SDP) += lcd_2430sdp.o
- objs-y$(CONFIG_MACH_OMAP_3430SDP) += lcd_2430sdp.o
- objs-y$(CONFIG_MACH_OMAP3EVM) += lcd_omap3evm.o
-+objs-y$(CONFIG_MACH_OMAP3_BEAGLE) += lcd_omap3beagle.o
- objs-y$(CONFIG_FB_OMAP_LCD_MIPID) += lcd_mipid.o
-
- omapfb-objs := $(objs-yy)
-diff --git a/drivers/video/omap/lcd_omap3beagle.c b/drivers/video/omap/lcd_omap3beagle.c
-new file mode 100644
-index 0000000..f5b7466
---- /dev/null
-+++ b/drivers/video/omap/lcd_omap3beagle.c
-@@ -0,0 +1,135 @@
-+/*
-+ * LCD panel support for the TI OMAP3 Beagle board
-+ *
-+ * Author: Koen Kooi <koen@openembedded.org>
-+ *
-+ * Derived from drivers/video/omap/lcd-omap3evm.c
-+ *
-+ * This program is free software; you can redistribute it and/or modify it
-+ * under the terms of the GNU General Public License as published by the
-+ * Free Software Foundation; either version 2 of the License, or (at your
-+ * option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License along
-+ * with this program; if not, write to the Free Software Foundation, Inc.,
-+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+#include <linux/i2c/twl4030.h>
-+
-+#include <asm/arch/gpio.h>
-+#include <asm/arch/mux.h>
-+#include <asm/arch/omapfb.h>
-+#include <asm/mach-types.h>
-+
-+#define LCD_PANEL_ENABLE_GPIO 170
-+
-+#define LCD_XRES 1024
-+#define LCD_YRES 768
-+#define LCD_PIXCLOCK_MAX 64000 /* in kHz */
-+#define LCD_PIXCLOCK_MIN 64000 /* in kHz */
-+
-+static int omap3beagle_panel_init(struct lcd_panel *panel,
-+ struct omapfb_device *fbdev)
-+{
-+ omap_request_gpio(LCD_PANEL_ENABLE_GPIO);
-+
-+ return 0;
-+}
-+
-+static void omap3beagle_panel_cleanup(struct lcd_panel *panel)
-+{
-+}
-+
-+static int omap3beagle_panel_enable(struct lcd_panel *panel)
-+{
-+ omap_set_gpio_dataout(LCD_PANEL_ENABLE_GPIO, 1);
-+ return 0;
-+}
-+
-+static void omap3beagle_panel_disable(struct lcd_panel *panel)
-+{
-+ omap_set_gpio_dataout(LCD_PANEL_ENABLE_GPIO, 0);
-+}
-+
-+static unsigned long omap3beagle_panel_get_caps(struct lcd_panel *panel)
-+{
-+ return 0;
-+}
-+
-+struct lcd_panel omap3beagle_panel = {
-+ .name = "omap3beagle",
-+ .config = OMAP_LCDC_PANEL_TFT,
-+
-+ .bpp = 24,
-+ .data_lines = 24,
-+ .x_res = LCD_XRES,
-+ .y_res = LCD_YRES,
-+ .hsw = 3, /* hsync_len (4) - 1 */
-+ .hfp = 3, /* right_margin (4) - 1 */
-+ .hbp = 39, /* left_margin (40) - 1 */
-+ .vsw = 1, /* vsync_len (2) - 1 */
-+ .vfp = 2, /* lower_margin */
-+ .vbp = 7, /* upper_margin (8) - 1 */
-+
-+ .pixel_clock = LCD_PIXCLOCK_MAX,
-+
-+ .init = omap3beagle_panel_init,
-+ .cleanup = omap3beagle_panel_cleanup,
-+ .enable = omap3beagle_panel_enable,
-+ .disable = omap3beagle_panel_disable,
-+ .get_caps = omap3beagle_panel_get_caps,
-+};
-+
-+static int omap3beagle_panel_probe(struct platform_device *pdev)
-+{
-+ omapfb_register_panel(&omap3beagle_panel);
-+ return 0;
-+}
-+
-+static int omap3beagle_panel_remove(struct platform_device *pdev)
-+{
-+ return 0;
-+}
-+
-+static int omap3beagle_panel_suspend(struct platform_device *pdev,
-+ pm_message_t mesg)
-+{
-+ return 0;
-+}
-+
-+static int omap3beagle_panel_resume(struct platform_device *pdev)
-+{
-+ return 0;
-+}
-+
-+struct platform_driver omap3beagle_panel_driver = {
-+ .probe = omap3beagle_panel_probe,
-+ .remove = omap3beagle_panel_remove,
-+ .suspend = omap3beagle_panel_suspend,
-+ .resume = omap3beagle_panel_resume,
-+ .driver = {
-+ .name = "omap3beagle_lcd",
-+ .owner = THIS_MODULE,
-+ },
-+};
-+
-+static int __init omap3beagle_panel_drv_init(void)
-+{
-+ return platform_driver_register(&omap3beagle_panel_driver);
-+}
-+
-+static void __exit omap3beagle_panel_drv_exit(void)
-+{
-+ platform_driver_unregister(&omap3beagle_panel_driver);
-+}
-+
-+module_init(omap3beagle_panel_drv_init);
-+module_exit(omap3beagle_panel_drv_exit);
---
-1.5.4.3
-
diff --git a/packages/linux/linux-omap2-git/beagleboard/defconfig b/packages/linux/linux-omap2-git/beagleboard/defconfig
index 8d238c6594..c5b893fc1f 100644
--- a/packages/linux/linux-omap2-git/beagleboard/defconfig
+++ b/packages/linux/linux-omap2-git/beagleboard/defconfig
@@ -1324,6 +1324,7 @@ CONFIG_SND_SOC=y
# SoC Audio for the Texas Instruments OMAP
#
CONFIG_SND_OMAP_SOC=y
+CONFIG_SND_OMAP_SOC_MCBSP=y
#
# Open Sound System
diff --git a/packages/linux/linux-omap2-git/beagleboard/l2-cache.patch b/packages/linux/linux-omap2-git/beagleboard/l2-cache.patch
deleted file mode 100644
index f35252283b..0000000000
--- a/packages/linux/linux-omap2-git/beagleboard/l2-cache.patch
+++ /dev/null
@@ -1,162 +0,0 @@
-From: "Syed Mohammed, Khasim" <khasim@ti.com>
-To: Koen Kooi <k.kooi@student.utwente.nl>
-CC: "linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>,
- "Woodruff,
- Richard" <r-woodruff2@ti.com>
-Date: Wed, 7 May 2008 13:12:13 +0530
-Subject: RE: public git l2 cache off.
-
-The below patch should get you going with L2 Cache enabled on GIT kernel, tested on Beagle board.
-
-Regards,
-Khasim
-
-
---- my_linux_omap/arch/arm/mm/Kconfig 2008-05-06 16:37:17.000000000 +0530
-+++ git/arch/arm/mm/Kconfig 2008-05-07 12:40:05.000000000 +0530
-@@ -659,6 +659,20 @@ config CPU_DCACHE_SIZE
- If your SoC is configured to have a different size, define the value
- here with proper conditions.
-
-+choice
-+ prompt "L2 Cache Size"
-+ depends on ARCH_OMAP34XX
-+
-+config CPU_LOCKDOWN_TO_64K_L2
-+ bool "Lock down L2 Cache to 64K"
-+
-+config CPU_LOCKDOWN_TO_128K_L2
-+ bool "Lock down L2 Cache to 128K"
-+
-+config CPU_LOCKDOWN_TO_256K_L2
-+ bool "Lock down L2 Cache to 256K"
-+endchoice
-+
- config CPU_DCACHE_WRITETHROUGH
- bool "Force write through D-cache"
- depends on (CPU_ARM740T || CPU_ARM920T || CPU_ARM922T || CPU_ARM925T || CPU_ARM926T || CPU_ARM940T || CPU_ARM946E || CPU_ARM1020) && !CPU_DCACHE_DISABLE
-@@ -674,6 +688,12 @@ config CPU_CACHE_ROUND_ROBIN
- Say Y here to use the predictable round-robin cache replacement
- policy. Unless you specifically require this or are unsure, say N.
-
-+config CPU_L2CACHE_DISABLE
-+ bool "Disable level 2 cache"
-+ depends on CPU_V7
-+ help
-+ Say Y here to disable the level 2 cache. If unsure, say N.
-+
- config CPU_BPREDICT_DISABLE
- bool "Disable branch prediction"
- depends on CPU_ARM1020 || CPU_V6 || CPU_XSC3 || CPU_V7
-
---- /tmp/proc-v7.S 2008-05-07 10:05:37.949232951 +0200
-+++ git/arch/arm/mm/proc-v7.S 2008-05-07 10:13:18.626067909 +0200
-@@ -182,11 +182,72 @@
- mov r10, #0x1f @ domains 0, 1 = manager
- mcr p15, 0, r10, c3, c0, 0 @ load domain access register
- #endif
-+#if defined(CONFIG_ARCH_OMAP3)
-+ @ L2 cache is enabled in the aux control register
-+ mrc p15, 0, r0, c1, c0, 1
-+ orr r0, r0, #0x11 @ speculative+no-alais protection
-+#ifdef CONFIG_CPU_L2CACHE_DISABLE
-+ bic r0, r0, #0x2 @ disable L2 Cache.
-+#else
-+ orr r0, r0, #0x2 @ enaable L2 Cache.
-+#endif
-+
-+/* On 3430 ES2.0 ZeBu and silicon, Aux Ctrl Reg can be written outside
-+ * Secure mode also
-+ */
-+ mcr p15, 0, r0, c1, c0, 1
-+
-+#ifdef CONFIG_ARCH_OMAP34XX
-+#ifdef CONFIG_CPU_LOCKDOWN_TO_64K_L2
-+ mov r10, #0xfc
-+ mcr p15, 1, r10, c9, c0, 0
-+#endif
-+
-+#ifdef CONFIG_CPU_LOCKDOWN_TO_128K_L2
-+ mov r10, #0xf0
-+ mcr p15, 1, r10, c9, c0, 0
-+#endif
-+
-+#ifdef CONFIG_CPU_LOCKDOWN_TO_256K_L2
-+ mov r10, #0x00
-+ mcr p15, 1, r10, c9, c0, 0
-+#endif
-+#endif
-+
- adr r5, v7_crval
- ldmia r5, {r5, r6}
-- mrc p15, 0, r0, c1, c0, 0 @ read control register
-- bic r0, r0, r5 @ clear bits them
-- orr r0, r0, r6 @ set them
-+ mrc p15, 0, r0, c1, c0, 0 @ read control register
-+ bic r0, r0, r5 @ clear bits them
-+ orr r0, r0, r6 @ set them
-+ mov pc, lr @ return to head.S:__ret
-+
-+ /*
-+ * TAT N EV F H R
-+ * .EFR M.EE .UI. ..A. .RVI Z... B... .CAM
-+ * 0xxx x0xx 11x0 01x1 0xxx x000 0111 1xxx < forced typical
-+ * r rr rr r rr r r rrr rrrr r < always read only
-+ * .000 ..00 ..0. ..0. .011 1... .... .101 < we want
-+ */
-+ .type v7_crval, #object
-+v7_crval:
-+ crval clear=0x7322f006, mmuset=0x00003805, ucset=0x00001804
-+#else
-+
-+#ifndef CONFIG_CPU_L2CACHE_DISABLE
-+ @ L2 cache configuration in the L2 aux control register
-+ mrc p15, 1, r10, c9, c0, 2
-+ bic r10, r10, #(1 << 16) @ L2 outer cache
-+ mcr p15, 1, r10, c9, c0, 2
-+ @ L2 cache is enabled in the aux control register
-+ mrc p15, 0, r10, c1, c0, 1
-+ orr r10, r10, #2
-+ mcr p15, 0, r10, c1, c0, 1
-+#endif
-+ mrc p15, 0, r0, c1, c0, 0 @ read control register
-+ ldr r10, cr1_clear @ get mask for bits to clear
-+ bic r0, r0, r10 @ clear bits them
-+ ldr r10, cr1_set @ get mask for bits to set
-+ orr r0, r0, r10 @ set them
- mov pc, lr @ return to head.S:__ret
-
- /*
-@@ -195,9 +256,13 @@
- * rrrr rrrx xxx0 0101 xxxx xxxx x111 xxxx < forced
- * 0 110 0011 1.00 .111 1101 < we want
- */
-- .type v7_crval, #object
--v7_crval:
-- crval clear=0x0120c302, mmuset=0x00c0387d, ucset=0x00c0187c
-+ .type cr1_clear, #object
-+ .type cr1_set, #object
-+cr1_clear:
-+ .word 0x0120c302
-+cr1_set:
-+ .word 0x00c0387d
-+#endif
-
- __v7_setup_stack:
- .space 4 * 11 @ 11 registers
-@@ -205,7 +270,6 @@
- .type v7_processor_functions, #object
- ENTRY(v7_processor_functions)
- .word v7_early_abort
-- .word pabort_ifar
- .word cpu_v7_proc_init
- .word cpu_v7_proc_fin
- .word cpu_v7_reset
-@@ -213,6 +277,7 @@
- .word cpu_v7_dcache_clean_area
- .word cpu_v7_switch_mm
- .word cpu_v7_set_pte_ext
-+ .word pabort_ifar
- .size v7_processor_functions, . - v7_processor_functions
-
- .type cpu_arch_name, #object
diff --git a/packages/linux/linux-omap2-git/beagleboard/usb-timout.patch b/packages/linux/linux-omap2-git/beagleboard/usb-timout.patch
deleted file mode 100644
index 2d1797cb66..0000000000
--- a/packages/linux/linux-omap2-git/beagleboard/usb-timout.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/ehci-hub.c 2008-04-30 11:41:59.381876290 +0200
-+++ git/drivers/usb/host/ehci-hub.c 2008-04-30 11:42:20.522875367 +0200
-@@ -734,7 +734,7 @@
- * this bit; seems too long to spin routinely...
- */
- retval = handshake(ehci, status_reg,
-- PORT_RESET, 0, 750);
-+ PORT_RESET, 0, 1250);
- if (retval != 0) {
- ehci_err (ehci, "port %d reset error %d\n",
- wIndex + 1, retval);