summaryrefslogtreecommitdiff
path: root/packages/linux/linux-n1200_2.6.27-rc9+git.bb
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-23 18:15:57 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-23 18:15:57 +0000
commitc914f8705032943d8cb2d8504ab7473fa98194cc (patch)
treebb8f879541660395cd35b7687cb15ed0908db6a1 /packages/linux/linux-n1200_2.6.27-rc9+git.bb
parent3a9aaf1187525764aaa7c624b98d89b6b74f47ad (diff)
linux-n1200: Fixup to use the right KERNEL_OUTPUT and use linux.inc
Diffstat (limited to 'packages/linux/linux-n1200_2.6.27-rc9+git.bb')
-rw-r--r--packages/linux/linux-n1200_2.6.27-rc9+git.bb19
1 files changed, 5 insertions, 14 deletions
diff --git a/packages/linux/linux-n1200_2.6.27-rc9+git.bb b/packages/linux/linux-n1200_2.6.27-rc9+git.bb
index 7378f0902c..c6ff65c119 100644
--- a/packages/linux/linux-n1200_2.6.27-rc9+git.bb
+++ b/packages/linux/linux-n1200_2.6.27-rc9+git.bb
@@ -1,8 +1,7 @@
DESCRIPTION = "Linux Kernel for the Thecus n1200"
SECTION = "kernel"
LICENSE = "GPL"
-PR = "r0"
-
+PR = "r1"
DEPENDS = "u-boot-mkimage-native"
COMPATIBLE_MACHINE = "n1200"
@@ -11,22 +10,14 @@ SRC_URI = "http://downloads.thecus.nas-central.org/N1200/Kernels/linux-2.6.27-fo
file://defconfig"
S = "${WORKDIR}/linux-2.6.27-foonas-git"
-inherit kernel
-
export ARCH="powerpc"
-KERNEL_IMAGETYPE = "zImage"
+# Bootloader is not device tree aware
+KERNEL_OUTPUT = "${S}/arch/powerpc/boot/cuImage.thecus_n1200"
+
+require linux.inc
do_configure() {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config
ARCH=${ARCH} oe_runmake oldconfig
}
-
-do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 ${S}/arch/powerpc/boot/cuImage.thecus_n1200 ${DEPLOY_DIR_IMAGE}/zImage
-}
-
-do_deploy[dirs] = "${S}"
-
-addtask deploy before do_package after do_install