summaryrefslogtreecommitdiff
path: root/packages/linux/linux-magicbox-2.6.19.2/904-ls_time_locale.patch
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-05-06 16:47:53 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-05-06 16:47:53 +0000
commit3fbd828c6fdcd947ec735c38ca9f700701d1354d (patch)
treeccc57653f1214858e347485b5c2308cf67353cde /packages/linux/linux-magicbox-2.6.19.2/904-ls_time_locale.patch
parent7c8380efe7ac5b7d7aaf01f91599bb5e64542710 (diff)
packages/linux/linux-magicbox_2.6.19.2.bb: Add kernel 2.6.19.2 for Magicbox
The patch set comes from Openwrt project
Diffstat (limited to 'packages/linux/linux-magicbox-2.6.19.2/904-ls_time_locale.patch')
-rw-r--r--packages/linux/linux-magicbox-2.6.19.2/904-ls_time_locale.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/linux/linux-magicbox-2.6.19.2/904-ls_time_locale.patch b/packages/linux/linux-magicbox-2.6.19.2/904-ls_time_locale.patch
new file mode 100644
index 0000000000..cc4a392b8f
--- /dev/null
+++ b/packages/linux/linux-magicbox-2.6.19.2/904-ls_time_locale.patch
@@ -0,0 +1,24 @@
+diff -urN linux-2.6.19.2/scripts/gen_initramfs_list.sh linux-2.6.19.2.new/scripts/gen_initramfs_list.sh
+--- linux-2.6.19.2/scripts/gen_initramfs_list.sh 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2.new/scripts/gen_initramfs_list.sh 2007-05-03 16:25:06.000000000 +0200
+@@ -120,9 +120,9 @@
+ ;;
+ "nod")
+ local dev_type=
+- local maj=$(LC_ALL=C ls -l "${location}" | \
++ local maj=$(LC_ALL=C ls --time-style=locale -l "${location}" | \
+ gawk '{sub(/,/, "", $5); print $5}')
+- local min=$(LC_ALL=C ls -l "${location}" | \
++ local min=$(LC_ALL=C ls --time-style=locale -l "${location}" | \
+ gawk '{print $6}')
+
+ if [ -b "${location}" ]; then
+@@ -133,7 +133,7 @@
+ str="${ftype} ${name} ${str} ${dev_type} ${maj} ${min}"
+ ;;
+ "slink")
+- local target=$(LC_ALL=C ls -l "${location}" | \
++ local target=$(LC_ALL=C ls --time-style=locale -l "${location}" | \
+ gawk '{print $11}')
+ str="${ftype} ${name} ${target} ${str}"
+ ;;