summaryrefslogtreecommitdiff
path: root/packages/linux/linux-jlime-sh3_2.6.17.bb
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2006-07-05 16:46:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-05 16:46:46 +0000
commitd8520f8034086c6a1ecc08b17d038448a6fef7ae (patch)
treea36ac87f9a70b11d3fe4b2ccddeb86f374880ec7 /packages/linux/linux-jlime-sh3_2.6.17.bb
parentfaa278eb98418094bcc3b4b9b4f9f40747811293 (diff)
parent1be1185ff9c0f9a80f5c76b06cfd7d1da06b56f6 (diff)
merge of 384828c9ac96947ed787099eb14a15f49ebedcac
and b3afec9600880ee22a3041769633491d0f81c427
Diffstat (limited to 'packages/linux/linux-jlime-sh3_2.6.17.bb')
-rw-r--r--packages/linux/linux-jlime-sh3_2.6.17.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/linux/linux-jlime-sh3_2.6.17.bb b/packages/linux/linux-jlime-sh3_2.6.17.bb
new file mode 100644
index 0000000000..185f1185c2
--- /dev/null
+++ b/packages/linux/linux-jlime-sh3_2.6.17.bb
@@ -0,0 +1,31 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for SuperH based Jornada 6xx"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_HOST = "sh.*-linux"
+#COMPATIBLE_MACHINE = "jornada6xx"
+
+SRC_URI = "http://www.kernel.orgm/pub/linux/kernel/v2.6/linux-2.6.17.tar.gz \
+ file://defconfig_jlime \
+ file://LinuxSH-2.6.17.patch;patch=0"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "arm"
+KERNEL_IMAGETYPE = "zImage"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig_jlime ${S}/.config
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/$(ARCH)/boot/$(KERNEL_IMAGETYPE) $(DEPLOY_DIR)/images/$(KERNEL_IMAGETYPE)
+}