summaryrefslogtreecommitdiff
path: root/packages/linux/linux-ixp4xx.inc
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-11-28 05:35:28 +0000
committerRod Whitby <rod@whitby.id.au>2007-11-28 05:35:28 +0000
commitf19c873a409ab4628ab5db2ddf12827063c0cfe8 (patch)
tree15aa61719bf93176bc3d50d5b1d7a2190a6e4c0c /packages/linux/linux-ixp4xx.inc
parentebc5a6179a680eadd5e7fc7ca985e2ce63fb90dc (diff)
linux-ixp4xx: Migration from ixp4xx-kernel. Intended to follow recent OE kernel recipe conventions. Default kernel for slugos distro and ixp4xx machines. ixp4xx-kernel will be removed later once this is well tested.
Diffstat (limited to 'packages/linux/linux-ixp4xx.inc')
-rw-r--r--packages/linux/linux-ixp4xx.inc26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/linux/linux-ixp4xx.inc b/packages/linux/linux-ixp4xx.inc
new file mode 100644
index 0000000000..02f80b06a1
--- /dev/null
+++ b/packages/linux/linux-ixp4xx.inc
@@ -0,0 +1,26 @@
+# linux-ixp4xx.inc
+#
+DESCRIPTION = "Linux 2.6.x kernel for IXP4xx devices"
+
+COMPATIBLE_HOST = 'arm.*-linux.*'
+COMPATIBLE_MACHINE = '(ixp4xx|nslu2)'
+
+# To specify the console set KERNEL_CONSOLE in the .bb file.
+
+# CMDLINE_ROOT: machine specific boot options - should not be set on a
+# generic kernel!
+CMDLINE_ROOT ?= ""
+
+# CMDLINE_DEBUG: debug options such as noirqdebug, defaults to empty
+# override in local.conf etc
+CMDLINE_DEBUG ?= ""
+
+CMDLINE = "${CMDLINE_ROOT}"
+CMDLINE += "${CMDLINE_DEBUG}"
+CMDLINE += "${CMDLINE_CONSOLE}"
+
+# Kernel module dependencies
+# (according to hrw, these should go in kernel.bbclass)
+
+DEPENDS_kernel-module-zd1211rw += "zd1211-firmware"
+RDEPENDS_kernel-module-zd1211rw += "zd1211-firmware"