summaryrefslogtreecommitdiff
path: root/packages/linux/linux-handhelds-2.6_cvs.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2006-11-03 00:02:55 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2006-11-03 00:02:55 +0000
commitdcc455f2d8ab7a7b57274aa81b02553b2c4a817d (patch)
tree3480fce479920f4173d6cc6c778990c75e53ebda /packages/linux/linux-handhelds-2.6_cvs.bb
parenta6aa992b13cdd88772b749c1c90249bb27d2f6c5 (diff)
linux-handhelds-2.6: Merge "_cvs" support into linux-handhelds-2.6.inc.
* Had to put SRC_URI to per-version .bb for that. * Tested ;-)
Diffstat (limited to 'packages/linux/linux-handhelds-2.6_cvs.bb')
-rw-r--r--packages/linux/linux-handhelds-2.6_cvs.bb64
1 files changed, 6 insertions, 58 deletions
diff --git a/packages/linux/linux-handhelds-2.6_cvs.bb b/packages/linux/linux-handhelds-2.6_cvs.bb
index 62c0fad9c9..ab08f1c596 100644
--- a/packages/linux/linux-handhelds-2.6_cvs.bb
+++ b/packages/linux/linux-handhelds-2.6_cvs.bb
@@ -2,69 +2,17 @@ SECTION = "kernel"
DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
LICENSE = "GPL"
PV = "${K_MAJOR}.${K_MINOR}.${K_MICRO}-hh${HHV}+cvs${SRCDATE}"
-PR = "r4"
-#
-COMPATIBLE_HOST = "arm.*-linux"
-COMPATIBLE_MACHINE = '(h3900|h5xxx|h2200|h4000|hx4700|htcuniversal|magician)'
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
-
-SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26 \
- file://24-hostap_cs_id.diff;patch=1 \
- file://hrw-pcmcia-ids-r2.patch;patch=1 \
- file://defconfig"
-
-S = "${WORKDIR}/kernel26"
-
-inherit kernel
-
-FILES_kernel-image_hx4700 = ""
-ALLOW_EMPTY_hx4700 = 1
-FILES_kernel-image_htcuniversal = ""
-ALLOW_EMPTY_htcuniversal = 1
+PR = "r5"
K_MAJOR = "2"
K_MINOR = "6"
K_MICRO = "17"
HHV = "2"
-#
-
-KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
-do_configure() {
-
- if [ `grep EXTRAVERSION Makefile | grep hh | awk '{print $3}' | sed s/-hh//` != ${HHV} ]; then
- die "-hh version mismatch"
- fi
-
- rm -f ${S}/.config
- if [ ! -e ${WORKDIR}/defconfig ]; then
- die "No default configuration for ${MACHINE} available."
- fi
-
-
- if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
- echo "CONFIG_AEABI=y" >> ${S}/.config
- echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
- else
- echo "# CONFIG_AEABI is not set" >> ${S}/.config
- echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
- fi
-
- sed -e '/CONFIG_AEABI/d' \
- -e '/CONFIG_OABI_COMPAT=/d' \
- '${WORKDIR}/defconfig' >>'${S}/.config'
-
- yes '' | oe_runmake oldconfig
-}
-
-do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
-}
-
-
-do_deploy[dirs] = "${S}"
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26 \
+ file://24-hostap_cs_id.diff;patch=1 \
+ file://hrw-pcmcia-ids-r2.patch;patch=1 \
+ file://defconfig"
-addtask deploy before do_package after do_compile
+require linux-handhelds-2.6.inc