summaryrefslogtreecommitdiff
path: root/packages/linux/linux-ezx_2.6.16.13.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-05-26 12:52:40 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-26 12:52:40 +0000
commitf4223494e69d4c3fb61ea068619363ed67987ef6 (patch)
treeb4385e2add0b2144cfaca7038e6c73a90f4a339d /packages/linux/linux-ezx_2.6.16.13.bb
parent04985b82fd2a1de2a73957e8c31eb2752c7dbb39 (diff)
linux-ezx: defconfig updates, add known good one as backup
Diffstat (limited to 'packages/linux/linux-ezx_2.6.16.13.bb')
-rw-r--r--packages/linux/linux-ezx_2.6.16.13.bb22
1 files changed, 8 insertions, 14 deletions
diff --git a/packages/linux/linux-ezx_2.6.16.13.bb b/packages/linux/linux-ezx_2.6.16.13.bb
index 29d7faf04e..1ae6377bdd 100644
--- a/packages/linux/linux-ezx_2.6.16.13.bb
+++ b/packages/linux/linux-ezx_2.6.16.13.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Michael 'Mickey' Lauer <mickey@vanille.de>"
LICENSE = "GPL"
DEPENDS += "quilt-native"
EZX = "ezx6"
-PR = "${EZX}-r2"
+PR = "${EZX}-r3"
inherit kernel
@@ -74,20 +74,14 @@ do_configure() {
yes '' | oe_runmake oldconfig
}
-# Check the kernel is below the 1264*1024 byte limit for the PXA Zaurii
+# Check the kernel is below the 1024*1024 byte limit for the boot-over usb
do_compile_append() {
- case ${MACHINE} in
- c7x0 | akita | poodle | spitz | tosa )
- size=`ls -l arch/${ARCH}/boot/${KERNEL_IMAGETYPE} | awk '{ print $5}'`
- if [ $size -ge 1294336 ]; then
- rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
- echo "Size is $size"
- die "This kernel is too big for your PXA Zaurus and will destroy data if you flash it. Please reduce the size of the kernel by making more of it modular."
- fi
- ;;
- *)
- ;;
- esac
+ size=`ls -l arch/${ARCH}/boot/${KERNEL_IMAGETYPE} | awk '{ print $5}'`
+ if [ $size -ge 1294336 ]; then
+ rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+ echo "Size is $size"
+ die "This kernel is too big for your EZX Phone. Please reduce the size of the kernel by making more of it modular."
+ fi
}
do_deploy() {