summaryrefslogtreecommitdiff
path: root/packages/linux/em-x270_2.6.23.bb
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2007-10-17 16:37:11 +0000
committerCliff Brake <cbrake@bec-systems.com>2007-10-17 16:37:11 +0000
commit6ac35c4a12465f744fadc9f7123ace504ef29f1d (patch)
tree1d287e7324ae1dccca62b0a893fd9c891bf8e6e6 /packages/linux/em-x270_2.6.23.bb
parentd4a39a9491b84814286f0816819bc048ba9d7e68 (diff)
em-x270: add machine/kernel support (from compulab)
em-x270 kernel recipe will likely be merged with linux_2.6.23 shortly ...
Diffstat (limited to 'packages/linux/em-x270_2.6.23.bb')
-rw-r--r--packages/linux/em-x270_2.6.23.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/linux/em-x270_2.6.23.bb b/packages/linux/em-x270_2.6.23.bb
new file mode 100644
index 0000000000..a9d6ee7905
--- /dev/null
+++ b/packages/linux/em-x270_2.6.23.bb
@@ -0,0 +1,29 @@
+require linux.inc
+
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the Compulab EM-X270 system"
+LICENSE = "GPL"
+DEPENDS = "uboot-utils"
+PR = "r0"
+
+KERNEL_IMAGETYPE = "uImage"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://em-x270.patch;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'arm.*-linux'
+COMPATIBLE_MACHINE = "em-x270"
+
+inherit kernel
+inherit package
+
+ARCH = "arm"
+
+FILES_kernel-image = ""
+
+S = "${WORKDIR}/linux-${PV}"
+