summaryrefslogtreecommitdiff
path: root/packages/libgcrypt
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-05-04 09:02:36 +0000
committerKoen Kooi <koen@openembedded.org>2008-05-04 09:02:36 +0000
commit4361a83c42b1cbd41dcfcd62d5069bd12ef85e1c (patch)
treee34f62e3c1fd6b90a5920726c2e836640d453c43 /packages/libgcrypt
parentcfd80451a81a9943c7a2e317a47a0d3b43a2ded0 (diff)
libgcrypt: add 1.4.1 and actually ship the pkgconfig file we add
Diffstat (limited to 'packages/libgcrypt')
-rw-r--r--packages/libgcrypt/libgcrypt-1.4.1/.mtn2git_empty0
-rw-r--r--packages/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch49
-rw-r--r--packages/libgcrypt/libgcrypt.inc10
-rw-r--r--packages/libgcrypt/libgcrypt_1.4.1.bb2
4 files changed, 57 insertions, 4 deletions
diff --git a/packages/libgcrypt/libgcrypt-1.4.1/.mtn2git_empty b/packages/libgcrypt/libgcrypt-1.4.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libgcrypt/libgcrypt-1.4.1/.mtn2git_empty
diff --git a/packages/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch b/packages/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch
new file mode 100644
index 0000000000..a4e5a65d65
--- /dev/null
+++ b/packages/libgcrypt/libgcrypt-1.4.1/add-pkgconfig-support.patch
@@ -0,0 +1,49 @@
+Index: libgcrypt-1.4.0/configure.ac
+===================================================================
+--- libgcrypt-1.4.0.orig/configure.ac
++++ libgcrypt-1.4.0/configure.ac
+@@ -1072,6 +1072,7 @@ cipher/Makefile
+ doc/Makefile
+ src/Makefile
+ src/gcrypt.h
++src/libgcrypt.pc
+ src/libgcrypt-config
+ src/versioninfo.rc
+ tests/Makefile
+Index: libgcrypt-1.4.0/src/libgcrypt.pc.in
+===================================================================
+--- /dev/null
++++ libgcrypt-1.4.0/src/libgcrypt.pc.in
+@@ -0,0 +1,32 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
++# Author: Simon Josefsson
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@LIBGCRYPT_CONFIG_API_VERSION@
++
++# Misc information.
++symmetric_ciphers=@LIBGCRYPT_CIPHERS@
++asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
++digests=@LIBGCRYPT_DIGESTS@
++
++Name: libgcrypt
++Description: GNU crypto library
++URL: http://www.gnupg.org
++Version: @VERSION@
++Libs: -L${libdir} -lgcrypt
++Libs.private: -L${libdir} -lgpg-error
++Cflags: -I${includedir}
diff --git a/packages/libgcrypt/libgcrypt.inc b/packages/libgcrypt/libgcrypt.inc
index 65f78db647..691f4fe133 100644
--- a/packages/libgcrypt/libgcrypt.inc
+++ b/packages/libgcrypt/libgcrypt.inc
@@ -7,16 +7,18 @@ DEPENDS = "libgpg-error"
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
file://add-pkgconfig-support.patch;patch=1"
-inherit autotools binconfig pkgconfig
+inherit autotools binconfig pkgconfig lib_package
EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
ARM_INSTRUCTION_SET = "arm"
+do_install_append() {
+ install -d ${D}/${libdir}/pkgconfig/
+ cp ${S}/src/*.pc ${D}/${libdir}/pkgconfig/
+}
+
do_stage() {
autotools_stage_all
}
-# move libgcrypt-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}"
diff --git a/packages/libgcrypt/libgcrypt_1.4.1.bb b/packages/libgcrypt/libgcrypt_1.4.1.bb
new file mode 100644
index 0000000000..c0b5e6531c
--- /dev/null
+++ b/packages/libgcrypt/libgcrypt_1.4.1.bb
@@ -0,0 +1,2 @@
+require libgcrypt.inc
+