summaryrefslogtreecommitdiff
path: root/packages/libao
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-08-25 09:40:49 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-25 09:40:49 +0000
commit08230069ad4b4ab6686d0467546e5f0125d54e3a (patch)
tree2ff044ba1c38f78921d60e78b5923ee33ffa4d1d /packages/libao
parent3ee0828904266168540bcc2672d20604666c4976 (diff)
parent0898ace54cb976203eefd94af7db6ef2917409f0 (diff)
merge of 1dee375784a345fa0f5a64a238267569e93342c5
and 3aec9f1e3ffb99d10a3a1025fe75aa3bcbef3e23
Diffstat (limited to 'packages/libao')
-rw-r--r--packages/libao/libao_0.8.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/libao/libao_0.8.6.bb b/packages/libao/libao_0.8.6.bb
new file mode 100644
index 0000000000..8c2601bce8
--- /dev/null
+++ b/packages/libao/libao_0.8.6.bb
@@ -0,0 +1,26 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cross platform audio library"
+HOMEPAGE = "http://www.xiph.org/ao/"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "http://www.xiph.org/ao/src/libao-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-esd --disable-esdtest \
+ --disable-alsa --disable-alsa09 \
+ --disable-arts --disable-nas"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/ao
+ install -m 0644 ${S}/include/ao/ao.h ${S}/include/ao/os_types.h \
+ ${S}/include/ao/plugin.h ${STAGING_INCDIR}/ao/
+
+ oe_libinstall -so -C src libao ${STAGING_LIBDIR}
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ao.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+FILES_${PN} += "${libdir}/ao/plugins-2/*.so"