summaryrefslogtreecommitdiff
path: root/packages/kexecboot
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-02-04 01:20:19 +0100
committerAndrea Adami <andrea.adami@gmail.com>2009-02-04 01:23:11 +0100
commitf457589a4e74a8ea3f9b03a4cbe0742900da1e78 (patch)
treed5589329f6c908865c646cbc6b9b9b0517f19981 /packages/kexecboot
parent9ca65a4ba59d37f08587c2b149c693500835eb2c (diff)
kexecboot: new recipe and refactoring
- added kexecboot_git.bb - moved most of shared things in kexecboot.inc - reworked kexecboot_0.4.bb -> PR bumped
Diffstat (limited to 'packages/kexecboot')
-rw-r--r--packages/kexecboot/kexecboot.inc39
-rw-r--r--packages/kexecboot/kexecboot_0.4.bb41
-rw-r--r--packages/kexecboot/kexecboot_git.bb15
3 files changed, 57 insertions, 38 deletions
diff --git a/packages/kexecboot/kexecboot.inc b/packages/kexecboot/kexecboot.inc
new file mode 100644
index 0000000000..201d3116d8
--- /dev/null
+++ b/packages/kexecboot/kexecboot.inc
@@ -0,0 +1,39 @@
+LICENSE = "GPL"
+
+DEPENDS = "klibc"
+RDEPENDS = "kexec-static"
+
+inherit autotools
+
+# You can create your own *-img.h by doing
+# ./make-image-header.sh <file>.png HAND
+
+SRC_URI += "file://logo-img.h \
+ file://logo.png \
+ "
+
+export CC=${TARGET_PREFIX}klcc
+
+# standard oe cflags don't work with klcc
+export CFLAGS = ""
+export CPPFLAGS = ""
+export LDFLAGS = ""
+
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
+ install -m 0644 ${WORKDIR}/logo.png ${S}/res/
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 kexecboot ${D}${bindir}/
+
+ install -d ${D}/proc
+ install -d ${D}/mnt
+}
+
+FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
+
+pkg_postinst_${PN} () {
+ ln -sf ${bindir}/kexecboot $D/init
+} \ No newline at end of file
diff --git a/packages/kexecboot/kexecboot_0.4.bb b/packages/kexecboot/kexecboot_0.4.bb
index 4eed4d0482..c38b2b402c 100644
--- a/packages/kexecboot/kexecboot_0.4.bb
+++ b/packages/kexecboot/kexecboot_0.4.bb
@@ -1,12 +1,4 @@
-LICENSE = "GPL"
-PR = "r4"
-DEPENDS = "klibc"
-RDEPENDS = "kexec-static"
-
-inherit autotools
-
-# You can create your own *-img.h by doing
-# ./make-image-header.sh <file>.png HAND
+PR = "r5"
SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
file://add-reboot-option.patch;patch=1 \
@@ -16,35 +8,8 @@ SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
file://add-sleep.patch;patch=1 \
file://silent-output-hack.patch;patch=1 \
file://kexecboot-tosa.patch;patch=1 \
- file://fb-render-16bit.patch;patch=1 \
- file://logo-img.h \
- file://logo.png \
- "
+ file://fb-render-16bit.patch;patch=1"
S = "${WORKDIR}/kexecboot-${PV}"
-export CC=${TARGET_PREFIX}klcc
-
-# standard oe cflags don't work with klcc
-export CFLAGS = ""
-export CPPFLAGS = ""
-export LDFLAGS = ""
-
-do_configure_prepend () {
- install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
- install -m 0644 ${WORKDIR}/logo.png ${S}/res/
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}/
-
- install -d ${D}/proc
- install -d ${D}/mnt
-}
-
-FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
-
-pkg_postinst_${PN} () {
- ln -sf ${bindir}/kexecboot $D/init
-}
+require kexecboot.inc
diff --git a/packages/kexecboot/kexecboot_git.bb b/packages/kexecboot/kexecboot_git.bb
new file mode 100644
index 0000000000..97a3f27512
--- /dev/null
+++ b/packages/kexecboot/kexecboot_git.bb
@@ -0,0 +1,15 @@
+PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "git://git.linuxtogo.org/home/thesing/kexecboot.git;protocol=git "
+SRCREV = "8823a939a38a8a3287f90dee062e8ab8569f884f"
+
+# v0.5
+#tag=8823a939a38a8a3287f90dee062e8ab8569f884f
+
+# v0.4
+#tag=d7af5356df4f25203831403c69f1a263c163f31a
+
+S = "${WORKDIR}/git"
+
+require kexecboot.inc