summaryrefslogtreecommitdiff
path: root/packages/kexecboot/initramfs-kexecboot_1.0.bb
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-08-04 00:04:58 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-08-04 00:04:58 +0000
commit2f3a8dec220aeb3c9dcd2b661cda56bb9abdbf6d (patch)
treed876c2d96c6cb39502500063eb71967a36f6f77b /packages/kexecboot/initramfs-kexecboot_1.0.bb
parent8763cfad52a31b4125e98ca61da98cb0ae615328 (diff)
parentcefb9bb3cb800983851a6b69180df6a93e8b14c2 (diff)
merge of '4d50db658eb49ec921eb903f0d6f18de6e4b5dd8'
and '9d2c8b10718f8a0a290e5537d400a454d9e65351'
Diffstat (limited to 'packages/kexecboot/initramfs-kexecboot_1.0.bb')
-rw-r--r--packages/kexecboot/initramfs-kexecboot_1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/kexecboot/initramfs-kexecboot_1.0.bb b/packages/kexecboot/initramfs-kexecboot_1.0.bb
new file mode 100644
index 0000000000..e1337419b8
--- /dev/null
+++ b/packages/kexecboot/initramfs-kexecboot_1.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTON = "A init script that mounts a device and kexecs a new kernel from it."
+PR = "r6"
+RDEPENDS = "kexecboot"
+do_compile() {
+ cat > init.sh << EOF
+#!/bin/sh
+/bin/mount -t proc proc /proc
+/usr/bin/kexecboot -a 270 -i /dev/event0
+EOF
+}
+
+do_install() {
+ install -m 0755 ${S}/init.sh ${D}/init
+ install -d ${D}/proc
+ install -d ${D}/mnt
+}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/init /proc /mnt"