summaryrefslogtreecommitdiff
path: root/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch')
-rw-r--r--packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch b/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch
deleted file mode 100644
index 9f1d253a93..0000000000
--- a/packages/ixp4xx/ixp4xx-csr-2.1.1/oe-makefile.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-changes to Makefile required only on OE
-
- Makefile | 11 ++++++++++-
- Makefile.kmod26 | 11 +++++++++++
- ixp400.c | 1 +
- 3 files changed, 22 insertions(+), 1 deletion(-)
-
-Index: ixp400_xscale_sw/Makefile
-===================================================================
---- ixp400_xscale_sw.orig/Makefile
-+++ ixp400_xscale_sw/Makefile
-@@ -1385,9 +1385,10 @@
-
- ifeq ($(IX_LINUXVER),2.6)
- ixp400 : $(OBJ_DIR)/ixp400.o
-+ cp $(OSAL_MODULE) $(OBJ_DIR)
- @echo 'EXTRA_LDFLAGS := --whole-archive' > $(OBJ_DIR)/Makefile
- @echo ' ' >> $(OBJ_DIR)/Makefile
-- @echo 'lib-m := $(COMPONENTS:%=ixp400_%.o) $(OBJ_DIR_EXIT)/$(OSAL_MODULE)'>> $(OBJ_DIR)/Makefile
-+ @echo 'lib-m := $(COMPONENTS:%=ixp400_%.o) ixp_osal.o'>> $(OBJ_DIR)/Makefile
- @echo ' ' >> $(OBJ_DIR)/Makefile
- @echo 'obj-m := ixp400.o' >> $(OBJ_DIR)/Makefile
- @echo ' ' >> $(OBJ_DIR)/Makefile
-@@ -1403,7 +1404,15 @@
-
- $(OBJ_DIR)/ixp400.o: $(COMPONENTS:%=$(OBJ_DIR)/ixp400_%.o) $(OSAL_MODULE)
- ifneq ($(IX_LINUXVER),2.6)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ touch $(OBJ_DIR)/ixp400.c
-+ cp Makefile.kmod26 $(OBJ_DIR)/Makefile
-+ make -C $(OBJ_DIR)
-+ rm -f $(OBJ_DIR)/ixp400.c
-+ cp ixp400.c $(OBJ_DIR)/ixp400.c
- $(LD) $(LDFLAGS) $^ -o $@
-+ rm -f $(OBJ_DIR)/ixp400.ko $(OBJ_DIR)/ixp400.mod.o
-+ make -C $(OBJ_DIR)
- endif
-
-
-Index: ixp400_xscale_sw/ixp400.c
-===================================================================
---- /dev/null
-+++ ixp400_xscale_sw/ixp400.c
-@@ -0,0 +1 @@
-+#error this file must never be compiled
-Index: ixp400_xscale_sw/Makefile.kmod26
-===================================================================
---- /dev/null
-+++ ixp400_xscale_sw/Makefile.kmod26
-@@ -0,0 +1,11 @@
-+obj-m := ixp400.o
-+
-+PWD := $(shell pwd)
-+
-+LINUX_SRC := $($(IX_TARGET)_KERNEL_DIR)
-+
-+default:
-+ $(MAKE) ARCH=arm CROSS_COMPILE=$(LINUX_CROSS_COMPILE) $(KERNEL_VERBOSE) -C $(LINUX_SRC) SUBDIRS=$(PWD) modules
-+
-+clean:
-+ rm -f ixp400.ko