summaryrefslogtreecommitdiff
path: root/packages/images/unslung-image.bb
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-11-13 19:19:49 +0000
committerMatt Reimer <mattjreimer@gmail.com>2006-11-13 19:19:49 +0000
commitfe6bc5b4cabb5fcf87b8944b4cfbe73bb48ceecf (patch)
treeb647d0f995205700148a392c69cccfe9077c7308 /packages/images/unslung-image.bb
parent2b622239c20657486f9e84842fd392f0a03c4598 (diff)
parentf7171587f09b13c97cc73109cd9eaf7c5aa78e47 (diff)
merge of '440352b74d1975abf361c30e00a2519bd5c8051e'
and '493bfe4db4e2664b2f5a442c4973208d987e2752'
Diffstat (limited to 'packages/images/unslung-image.bb')
-rw-r--r--packages/images/unslung-image.bb53
1 files changed, 29 insertions, 24 deletions
diff --git a/packages/images/unslung-image.bb b/packages/images/unslung-image.bb
index 1deab932c7..3fa3607e83 100644
--- a/packages/images/unslung-image.bb
+++ b/packages/images/unslung-image.bb
@@ -1,7 +1,9 @@
LICENSE = MIT
-PR = "r22"
+PR = "r25"
+COMPATIBLE_MACHINE = "nslu2"
IMAGE_BASENAME = "unslung"
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}-${DISTRO_VERSION}"
IMAGE_LINGUAS = ""
USE_DEVFS = "1"
@@ -10,15 +12,17 @@ DEPENDS = "virtual/kernel \
${UNSLUNG_EXTRA_DEPENDS}"
RDEPENDS = "kernel update-modules unslung-rootfs \
- libc6-unslung slingbox ipkg libipkg \
- cpio \
- findutils \
+ libc6-unslung slingbox ipkg \
+ libipkg \
+# cpio \
+# findutils \
${UNSLUNG_EXTRA_RDEPENDS}"
IPKG_INSTALL = "kernel update-modules unslung-rootfs \
- libc6-unslung slingbox ipkg libipkg \
- cpio \
- findutils \
+ libc6-unslung slingbox ipkg \
+ libipkg \
+# cpio \
+# findutils \
kernel-module-netconsole \
${UNSLUNG_EXTRA_INSTALL}"
@@ -72,25 +76,26 @@ unslung_clean_image () {
${STRIP} ${IMAGE_ROOTFS}/lib/libgcc_s.so.1
chmod ugo+x ${IMAGE_ROOTFS}/lib/libgcc_s.so.1
+# MJW - experimental right now, but no longer need cpio and find
# We need cpio and find, but we don't need any of the other stuff in
# the packages (users can install the full package with ipkg after
# unsling). Remove the extra files and executables, and clean up
# the entries from the ipkg database manually.
#-- these are for cpio:
- rm -f ${IMAGE_ROOTFS}/usr/bin/mt
- rm -rf ${IMAGE_ROOTFS}/usr/libexec
- rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/cpio.*
- rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/alternatives/rmt
- sed -i -e '/^Package: cpio/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
+# rm -f ${IMAGE_ROOTFS}/usr/bin/mt
+# rm -rf ${IMAGE_ROOTFS}/usr/libexec
+# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/cpio.*
+# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/alternatives/rmt
+# sed -i -e '/^Package: cpio/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
#-- and these for find:
- rm -f ${IMAGE_ROOTFS}/usr/bin/locate
- rm -f ${IMAGE_ROOTFS}/usr/bin/updatedb
- rm -f ${IMAGE_ROOTFS}/usr/bin/xargs
- rm -f ${IMAGE_ROOTFS}/usr/bin/xargs.findutils
- rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/findutils.*
- sed -i -e '/^Package: findutils/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
+# rm -f ${IMAGE_ROOTFS}/usr/bin/locate
+# rm -f ${IMAGE_ROOTFS}/usr/bin/updatedb
+# rm -f ${IMAGE_ROOTFS}/usr/bin/xargs
+# rm -f ${IMAGE_ROOTFS}/usr/bin/xargs.findutils
+# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/findutils.*
+# sed -i -e '/^Package: findutils/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
# FIXME: change made 24 Jul 2006 by the OE folks changes the "strip"
# behavior to create an extra file named .debug/<filename> containing
@@ -107,11 +112,11 @@ unslung_clean_image () {
rm -rf ${IMAGE_ROOTFS}/usr/bin/.debug
rm -rf ${IMAGE_ROOTFS}/usr/sbin/.debug
rm -rf ${IMAGE_ROOTFS}/usr/lib/.debug
-}
-python () {
- # Don't build unslung images unless we're targeting an nslu2
- mach = bb.data.getVar("MACHINE", d, 1)
- if mach != 'nslu2':
- raise bb.parse.SkipPackage("Unslung only builds for the Linksys NSLU2")
+# MJW - Experimental - just to make space; remove before releasing!
+# #### Hack to make space for testing! REMOVE THIS!
+# rm -rf ${IMAGE_ROOTFS}/etc/samba/codepages/unicode_map.850
+# rm -rf ${IMAGE_ROOTFS}/bin/ftp
+# #### End of Hack!
+
}