summaryrefslogtreecommitdiff
path: root/packages/images/nylon-image-base.bb
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2006-09-08 12:52:43 +0000
committerMartin Dietze <di@fh-wedel.de>2006-09-08 12:52:43 +0000
commit30596c3e0a0216faaaa5b1ffaa4bd0e2c816eb21 (patch)
tree41173d7708d23aba6ffb9ba20a8ffc6b40146d99 /packages/images/nylon-image-base.bb
parentabf168554971b3e714dd2ee2bbebf18ab91121e9 (diff)
nylon: updated images and nylon specific packages from 4G trunk
* updated list of supported packages in nylon-feed * new image nylon-image-extended aiming to put nylon-feed into one image (for debugging) * new versions of nylon-scripts, nylon-statistics, simple-firewall
Diffstat (limited to 'packages/images/nylon-image-base.bb')
-rw-r--r--packages/images/nylon-image-base.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/packages/images/nylon-image-base.bb b/packages/images/nylon-image-base.bb
index a4f6d17dd8..4e7711e6c7 100644
--- a/packages/images/nylon-image-base.bb
+++ b/packages/images/nylon-image-base.bb
@@ -1,3 +1,6 @@
+inherit image_ipk nylon-image
+LICENSE = MIT
+
export IMAGE_BASENAME = "nylon-base"
NYLON_BASE = "base-files base-passwd bash busybox \
@@ -7,8 +10,8 @@ NYLON_BASE = "base-files base-passwd bash busybox \
openssh sysvinit \
timezones tinylogin"
-DEPENDS = "virtual/kernel"
-RDEPENDS = "kernel modutils-depmod modutils-modinfo \
+DEPENDS += "virtual/kernel less nano"
+RDEPENDS = "kernel modutils-depmod modutils-modinfo less nano \
${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
export IPKG_INSTALL = "${RDEPENDS}"
@@ -19,4 +22,3 @@ IMAGE_LINGUAS = ""
ROOTFS_POSTPROCESS_COMMAND = "rm -f ${IMAGE_ROOTFS}/tmp/zImage*"
inherit image_ipk nylon-image
-LICENSE = MIT