summaryrefslogtreecommitdiff
path: root/packages/hostap/hostap-daemon_0.3.7.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/hostap/hostap-daemon_0.3.7.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/hostap/hostap-daemon_0.3.7.bb')
-rw-r--r--packages/hostap/hostap-daemon_0.3.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/hostap/hostap-daemon_0.3.7.bb b/packages/hostap/hostap-daemon_0.3.7.bb
index e69de29bb2..9363a10d91 100644
--- a/packages/hostap/hostap-daemon_0.3.7.bb
+++ b/packages/hostap/hostap-daemon_0.3.7.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV}) hostap-utils (${PV})"
+DEPENDS_mtx-1_append = "madwifi-modules"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+ file://makefile-cross.diff;patch=1;pnum=0 \
+ file://madwifi-bsd-fix.diff;patch=1;pnum=0 \
+ file://defconfig \
+ file://init"
+
+S = "${WORKDIR}/hostapd-${PV}"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+do_compile() {
+ CFLAGS='${CFLAGS}' CC='${CC}' make
+}
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ make TARGET_PREFIX=${D}${sbindir} install
+ install -m 0644 hostapd.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}