summaryrefslogtreecommitdiff
path: root/packages/hostap/hostap-daemon-0.6.0
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-11 09:42:16 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-11 09:42:16 +0000
commit7bcf4828673040af5022534981de6416f5884cff (patch)
tree18ab00a9b6f1ce29fa7b613662e256785fb59781 /packages/hostap/hostap-daemon-0.6.0
parent84b2b31930881004a73267cf24fe6fe701e0f8a8 (diff)
parent78c32ad25a3883dc7a127a36673890225f9f54f2 (diff)
propagate from branch 'org.openembedded.dev' (head acccc4840b95c279164a3eeacf893200164bdc65)
to branch 'org.openembedded.dev.avr32' (head 4a915ee0a28076c53049330f3f2e58c7b85ef7a8)
Diffstat (limited to 'packages/hostap/hostap-daemon-0.6.0')
-rw-r--r--packages/hostap/hostap-daemon-0.6.0/.mtn2git_empty0
-rw-r--r--packages/hostap/hostap-daemon-0.6.0/init37
-rw-r--r--packages/hostap/hostap-daemon-0.6.0/makefile-cross.diff25
3 files changed, 62 insertions, 0 deletions
diff --git a/packages/hostap/hostap-daemon-0.6.0/.mtn2git_empty b/packages/hostap/hostap-daemon-0.6.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.6.0/.mtn2git_empty
diff --git a/packages/hostap/hostap-daemon-0.6.0/init b/packages/hostap/hostap-daemon-0.6.0/init
new file mode 100644
index 0000000000..79f74b681e
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.6.0/init
@@ -0,0 +1,37 @@
+#!/bin/sh
+DAEMON=/usr/sbin/hostapd
+NAME=hostapd
+DESC="HOSTAP Daemon"
+ARGS="/etc/hostapd.conf -B"
+
+test -f $DAEMON || exit 0
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ start-stop-daemon -S -x $DAEMON -- $ARGS
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon -K -x $DAEMON
+ echo "$NAME."
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ reload)
+ echo -n "Reloading $DESC: "
+ killall -HUP $(basename ${DAEMON})
+ echo "$NAME."
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/hostap/hostap-daemon-0.6.0/makefile-cross.diff b/packages/hostap/hostap-daemon-0.6.0/makefile-cross.diff
new file mode 100644
index 0000000000..9534199e78
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.6.0/makefile-cross.diff
@@ -0,0 +1,25 @@
+diff -urN hostapd.orig/Makefile hostapd/Makefile
+--- hostapd.orig/Makefile 2007-05-28 19:26:55.000000000 +0200
++++ hostapd/Makefile 2007-11-22 16:28:44.000000000 +0100
+@@ -6,6 +6,8 @@
+ CFLAGS = -MMD -O2 -Wall -g
+ endif
+
++TARGET_PREFIX ?= /usr/local/bin/
++
+ # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
+ # a file (undefine it, if you want to save in binary size)
+ CFLAGS += -DHOSTAPD_DUMP_STATE
+@@ -361,10 +363,10 @@
+ fi
+
+ install: all
+- for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
++ for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
+
+ hostapd: $(OBJS)
+- $(CC) -o hostapd $(OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
+
+ OBJS_c = hostapd_cli.o ../src/common/wpa_ctrl.o ../src/utils/os_$(CONFIG_OS).o
+ hostapd_cli: $(OBJS_c)