summaryrefslogtreecommitdiff
path: root/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-04-28 19:01:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-04-28 19:01:32 +0000
commit5a51f37cecd6640ef544a8b511d444ee9afb1e34 (patch)
treeef8052b5c55a92e29468f9888ebacd1298430deb /packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff
parent0ab106f1f08f87203e7bcdb1ec896d1e62a65416 (diff)
parent36b64099ff67b193c65de69009ae054a32790aff (diff)
merge of '322ea19f98c9c37886c8eb080fbd9c6a552f7b1d'
and 'bbaee78aa2be4934e6fb2377a1ef53589b7e3b7c'
Diffstat (limited to 'packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff')
-rw-r--r--packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff b/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff
new file mode 100644
index 0000000000..43b275c67b
--- /dev/null
+++ b/packages/hostap/hostap-daemon-0.5.10/makefile-cross.diff
@@ -0,0 +1,31 @@
+diff -urN hostapd-0.5.10.orig/Makefile hostapd-0.5.10/Makefile
+--- hostapd-0.5.10.orig/Makefile 2008-02-20 01:08:54.000000000 +0100
++++ hostapd-0.5.10/Makefile 2008-04-28 17:01:36.000000000 +0200
+@@ -1,10 +1,14 @@
++ifndef CC
+ CC=gcc
++endif
+ DIR_WPA_SUPPLICANT=.
+
+ ifndef CFLAGS
+ CFLAGS = -MMD -O2 -Wall -g
+ endif
+
++TARGET_PREFIX ?= /usr/local/bin/
++
+ # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
+ # a file (undefine it, if you want to save in binary size)
+ CFLAGS += -DHOSTAPD_DUMP_STATE
+@@ -333,10 +337,10 @@
+ fi
+
+ install: all
+- for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
++ for i in $(ALL); do cp $$i $(TARGET_PREFIX)/$$i; done
+
+ hostapd: $(OBJS)
+- $(CC) -o hostapd $(OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -o hostapd $(OBJS) $(LIBS)
+
+ driver_conf.c: Makefile .config
+ rm -f driver_conf.c