summaryrefslogtreecommitdiff
path: root/packages/h2200-bootloader
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-07-24 23:37:01 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-07-24 23:37:01 +0000
commita3e73146adce111fe67af0886a43acbf7a654bd7 (patch)
tree2f16f88686bb2a878ce3942053cbbb2de0ed965f /packages/h2200-bootloader
parent0196a9e9747d4460e7ab28a63494f56dfe5c8297 (diff)
parent28dfae00ff3dc61e1f02dc9d14b1ff40ee3a4f59 (diff)
merge of 'd2f1a9f3ef64d23cec1e794848e1bb2ac1a92e63'
and 'ed4e5b420b127a2a4f722c324c8c61ee00caf977'
Diffstat (limited to 'packages/h2200-bootloader')
-rw-r--r--packages/h2200-bootloader/h2200-bootloader.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/h2200-bootloader/h2200-bootloader.bb b/packages/h2200-bootloader/h2200-bootloader.bb
index dc7c2277a8..5db3cd058d 100644
--- a/packages/h2200-bootloader/h2200-bootloader.bb
+++ b/packages/h2200-bootloader/h2200-bootloader.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Bootloader firmware extractor for the h2200 iPAQ"
+RRECOMMENDS_${PN} = "kernel-module-mtdblock"
ALLOW_EMPTY = "1"
-PR="r2"
+PR = "r3"
COMPATIBLE_MACHINE = "h2200"
#it is a shell script, but lets protect the innocent some more
@@ -9,5 +10,6 @@ PACKAGE_ARCH = "h2200"
pkg_postinst() {
#!/bin/sh
mkdir -p /lib/firmware
+modprobe mtdblock
dd if=/dev/mtdblock0 of=/lib/firmware/h2200_bootloader.bin 2>/dev/null
}