summaryrefslogtreecommitdiff
path: root/packages/guile/files
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-07-02 13:50:18 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-02 13:50:18 +0000
commitc4ad3b40f4e5eb92adf68db603c9eebc50bc367b (patch)
tree707875839f256cfd322604cb9dc6850d8f748d92 /packages/guile/files
parent0f9202fb5e73731751b6aef3411f966c2756f1d0 (diff)
guile 1.6.4 add patch for building with gcc4. reorder and enhance metadata
Diffstat (limited to 'packages/guile/files')
-rw-r--r--packages/guile/files/.mtn2git_empty0
-rw-r--r--packages/guile/files/configure-lossage.patch28
-rw-r--r--packages/guile/files/gcc4.patch16
3 files changed, 44 insertions, 0 deletions
diff --git a/packages/guile/files/.mtn2git_empty b/packages/guile/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/guile/files/.mtn2git_empty
diff --git a/packages/guile/files/configure-lossage.patch b/packages/guile/files/configure-lossage.patch
new file mode 100644
index 0000000000..da1d0de6e7
--- /dev/null
+++ b/packages/guile/files/configure-lossage.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- guile-1.6.4/configure.in~configure-lossage
++++ guile-1.6.4/configure.in
+@@ -462,7 +462,9 @@
+ # explicitly to LIBOBJS to make sure that it is translated to
+ # `alloca.lo' for libtool later on. This can and should be done more cleanly.
+ AC_FUNC_ALLOCA
+-if test "$ALLOCA" = "alloca.o"; then AC_LIBOBJ([alloca]); fi
++if test "$ALLOCA" = "alloca.o"; then
++ AC_LIBOBJ([alloca])
++fi
+
+ AC_CHECK_MEMBERS([struct stat.st_rdev])
+ AC_CHECK_MEMBERS([struct stat.st_blksize])
+--- guile-1.6.4/guile-readline/configure.in~configure-lossage
++++ guile-1.6.4/guile-readline/configure.in
+@@ -2,6 +2,7 @@
+
+ AC_INIT
+ AC_CONFIG_SRCDIR([readline.c])
++AC_CONFIG_AUX_DIR([..])
+ . $srcdir/../GUILE-VERSION
+ PACKAGE=guile-readline
+ AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
diff --git a/packages/guile/files/gcc4.patch b/packages/guile/files/gcc4.patch
new file mode 100644
index 0000000000..2168683ad5
--- /dev/null
+++ b/packages/guile/files/gcc4.patch
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- guile-1.6.4/libguile/guile.c~gcc4
++++ guile-1.6.4/libguile/guile.c
+@@ -88,7 +88,7 @@
+ {
+ #ifdef DYNAMIC_LINKING
+ /* libtool automagically inserts this variable into your executable... */
+- extern const scm_lt_dlsymlist lt_preloaded_symbols[];
++ extern const scm_lt_dlsymlist *lt_preloaded_symbols;
+ scm_lt_dlpreload_default (lt_preloaded_symbols);
+ #endif
+ scm_boot_guile (argc, argv, inner_main, 0);