summaryrefslogtreecommitdiff
path: root/packages/gtk-webcore/files
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-02-16 07:10:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-16 07:10:37 +0000
commit4970f35df054e8a6627b48441ba1d970e435a2ae (patch)
tree2bce3b9ba858dc696240dd1d52c34a479d515307 /packages/gtk-webcore/files
parent49febb21d31a03f8729c1cdc9f7e4b580455b8cc (diff)
gtk-webcore: add gcc4 patches for jscore, nrcit, and nrcore, fixes bug #684, thanks to Eric Shattow
Diffstat (limited to 'packages/gtk-webcore/files')
-rw-r--r--packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-JavaScriptCore.patch12
-rw-r--r--packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCit.patch12
-rw-r--r--packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCore.patch12
3 files changed, 36 insertions, 0 deletions
diff --git a/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-JavaScriptCore.patch b/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-JavaScriptCore.patch
new file mode 100644
index 0000000000..d48644cf5e
--- /dev/null
+++ b/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-JavaScriptCore.patch
@@ -0,0 +1,12 @@
+diff -bur JavaScriptCore~orig/configure.in JavaScriptCore/configure.in
+--- JavaScriptCore~orig/configure.in 2006-02-12 01:51:50.000000000 -0600
++++ JavaScriptCore/configure.in 2006-02-12 22:26:44.000000000 -0600
+@@ -63,7 +63,7 @@
+ fi
+ changequote([,])dnl
+
+-CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++"
++CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++ -fno-threadsafe-statics"
+ LDFLAGS="$LDFLAGS $PACKAGE_LIBS" #-nodefaultlibs -lgcc -lc -lm"
+
+ CPPFLAGS="$CPPFLAGS $PACKAGE_CFLAGS -I\$(top_srcdir)/kjs -I\$(top_srcdir)/pcre -I\$(top_srcdir)/"
diff --git a/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCit.patch b/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCit.patch
new file mode 100644
index 0000000000..bee942fa9a
--- /dev/null
+++ b/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCit.patch
@@ -0,0 +1,12 @@
+diff -bur NRCit~orig/configure.in NRCit/configure.in
+--- NRCit~orig/configure.in 2005-08-08 18:07:00.000000000 -0500
++++ NRCit/configure.in 2006-02-12 21:28:53.000000000 -0600
+@@ -37,7 +37,7 @@
+ esac
+ case " $CXXFLAGS " in
+ *[\ \ ]-Wall[\ \ ]*) ;;
+- *) CXXFLAGS="$CXXFLAGS -Wall -Werror" ;;
++ *) CXXFLAGS="$CXXFLAGS -Wall -Werror -fno-threadsafe-statics" ;;
+ esac
+ fi
+ changequote([,])dnl
diff --git a/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCore.patch b/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCore.patch
new file mode 100644
index 0000000000..d3cb8c9b47
--- /dev/null
+++ b/packages/gtk-webcore/files/gcc4-fno-threadsafe-statics-NRCore.patch
@@ -0,0 +1,12 @@
+diff -bur NRCore~orig/configure.in NRCore/configure.in
+--- NRCore~orig/configure.in 2005-02-16 03:31:43.000000000 -0600
++++ NRCore/configure.in 2006-02-12 21:03:49.000000000 -0600
+@@ -107,7 +107,7 @@
+ esac
+ case " $CXXFLAGS " in
+ *[\ \ ]-Wall[\ \ ]*) ;;
+- *) CXXFLAGS="$CXXFLAGS -Wall " ;;
++ *) CXXFLAGS="$CXXFLAGS -Wall -fno-threadsafe-statics " ;;
+ esac
+ fi
+ changequote([,])dnl