summaryrefslogtreecommitdiff
path: root/packages/gstreamer/gst-plugins
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-13 21:09:42 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-13 21:09:42 +0000
commitd2f11bf46d4b6929b75b786171105561f91a525c (patch)
tree8faece2823212f6bc8ed6e6491a6bea5469025a2 /packages/gstreamer/gst-plugins
parentf45a26339f26a4da01166c1969c5ea620f992883 (diff)
gstreamer: bump to gstreamer-0.8.10. apply patch submitted in gnome bug #313322. move patches around a bit.
Diffstat (limited to 'packages/gstreamer/gst-plugins')
-rw-r--r--packages/gstreamer/gst-plugins/lame-autoconf.patch21
-rw-r--r--packages/gstreamer/gst-plugins/try-esdsink.patch22
2 files changed, 43 insertions, 0 deletions
diff --git a/packages/gstreamer/gst-plugins/lame-autoconf.patch b/packages/gstreamer/gst-plugins/lame-autoconf.patch
new file mode 100644
index 0000000000..3fb85e7d88
--- /dev/null
+++ b/packages/gstreamer/gst-plugins/lame-autoconf.patch
@@ -0,0 +1,21 @@
+--- gst-plugins-0.8.6.orig/configure.ac 2004-11-25 16:41:47.000000000 +0100
++++ gst-plugins-0.8.6/configure.ac 2005-02-22 19:02:58.000000000 +0100
+@@ -1135,8 +1135,9 @@
+ GST_CHECK_LIBHEADER(LAME, mp3lame, lame_init, -lm, lame/lame.h, HAVE_LAME="yes" LAME_LIBS="-lmp3lame -lm")
+ ])
+ dnl is lame presets available
++if test "x$HAVE_LAME" = "xyes"; then
+ LAME_CFLAGS=""
+-AC_TRY_RUN([
++AC_TRY_COMPILE([
+ #include <lame/lame.h>
+ int main (int argc, char *argv[])
+ {
+@@ -1144,6 +1145,7 @@
+ return 0;
+ }
+ ],[LAME_CFLAGS="-DGSTLAME_PRESET"],[LAME_CFLAGS=""])
++fi
+ AC_SUBST(LAME_CFLAGS)
+ AC_SUBST(LAME_LIBS)
+
diff --git a/packages/gstreamer/gst-plugins/try-esdsink.patch b/packages/gstreamer/gst-plugins/try-esdsink.patch
new file mode 100644
index 0000000000..9c6242663c
--- /dev/null
+++ b/packages/gstreamer/gst-plugins/try-esdsink.patch
@@ -0,0 +1,22 @@
+--- gst-plugins-0.8.1/gst-libs/gst/gconf/gconf.c~ 2004-08-17 17:55:46.000000000 +0100
++++ gst-plugins-0.8.1/gst-libs/gst/gconf/gconf.c 2004-08-17 18:04:00.000000000 +0100
+@@ -204,10 +204,16 @@
+ if (!ret) {
+ ret = gst_element_factory_make ("osssink", NULL);
+
+- if (!ret)
+- g_warning ("No GConf default audio sink key and osssink doesn't work");
+- else
++ if (!ret) {
++ ret = gst_element_factory_make ("esdsink", NULL);
++
++ if (!ret)
++ g_warning ("No GConf default audio sink key and osssink & esdsink don't work");
++ else
++ g_print ("GConf audio sink and osssink not found, using esdsink\n");
++ } else {
+ g_print ("GConf audio sink not found, using osssink\n");
++ }
+ }
+
+ return ret;