summaryrefslogtreecommitdiff
path: root/packages/gstreamer/gst-plugins-0.8.8
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-13 21:49:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-13 21:49:24 +0000
commit066ad20236b7e9291f771e51499124762fbd510c (patch)
tree6265dd6ab2d70ba0210d8ed1e93aa15625edf05b /packages/gstreamer/gst-plugins-0.8.8
parentd2f11bf46d4b6929b75b786171105561f91a525c (diff)
gst-plugins: bump to gst-plugins-0.8.8. update try-esd.patch to work with current code.
Diffstat (limited to 'packages/gstreamer/gst-plugins-0.8.8')
-rw-r--r--packages/gstreamer/gst-plugins-0.8.8/.mtn2git_empty0
-rw-r--r--packages/gstreamer/gst-plugins-0.8.8/gst-plugins-0.8.8-try-esdsink.patch19
-rw-r--r--packages/gstreamer/gst-plugins-0.8.8/lame-autoconf.patch11
3 files changed, 30 insertions, 0 deletions
diff --git a/packages/gstreamer/gst-plugins-0.8.8/.mtn2git_empty b/packages/gstreamer/gst-plugins-0.8.8/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gstreamer/gst-plugins-0.8.8/.mtn2git_empty
diff --git a/packages/gstreamer/gst-plugins-0.8.8/gst-plugins-0.8.8-try-esdsink.patch b/packages/gstreamer/gst-plugins-0.8.8/gst-plugins-0.8.8-try-esdsink.patch
new file mode 100644
index 0000000000..553c7b4270
--- /dev/null
+++ b/packages/gstreamer/gst-plugins-0.8.8/gst-plugins-0.8.8-try-esdsink.patch
@@ -0,0 +1,19 @@
+--- gst-plugins-0.8.8.orig/gst-libs/gst/gconf/gconf.c 2005-02-02 09:14:01.000000000 +0100
++++ gst-plugins-0.8.8/gst-libs/gst/gconf/gconf.c 2005-08-13 23:28:36.000000000 +0200
+@@ -205,9 +205,13 @@
+ if (!ret) {
+ ret = gst_element_factory_make (DEFAULT_AUDIOSINK, NULL);
+
+- if (!ret)
+- g_warning ("No GConf default audio sink key and %s doesn't work",
+- DEFAULT_AUDIOSINK);
++ if (!ret) {
++ ret = gst_element_factory_make ("esdsink", NULL);
++
++ if (!ret)
++ g_warning ("No GConf default audio sink key and neither %s nor esdsink work",
++ DEFAULT_AUDIOSINK);
++ }
+ }
+
+ return ret;
diff --git a/packages/gstreamer/gst-plugins-0.8.8/lame-autoconf.patch b/packages/gstreamer/gst-plugins-0.8.8/lame-autoconf.patch
new file mode 100644
index 0000000000..6f2a300254
--- /dev/null
+++ b/packages/gstreamer/gst-plugins-0.8.8/lame-autoconf.patch
@@ -0,0 +1,11 @@
+--- gst-plugins-0.8.7/configure.ac.orig 2005-03-03 16:40:45.000000000 +0100
++++ gst-plugins-0.8.7/configure.ac 2005-03-03 16:41:55.000000000 +0100
+@@ -1197,7 +1197,7 @@
+ LAME_LIBS="-lmp3lame -lm"
+ dnl is lame presets available
+ LAME_CFLAGS=""
+- AC_TRY_RUN([
++ AC_TRY_COMPILE([
+ #include <lame/lame.h>
+ int main (int argc, char *argv[])
+ {