summaryrefslogtreecommitdiff
path: root/packages/gpm/gpm_1.20.1.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-01-16 18:04:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-01-16 18:04:08 +0000
commitf704267b58de181fff67d0ab0c45ea4a40da687a (patch)
tree43419e3e2deb6915d5c02e49d4326b8011defc92 /packages/gpm/gpm_1.20.1.bb
parenteb485afd8f028a7d128d500f05418d88260e9c95 (diff)
parent16cb2f321befd4c69c9c938c2ec8386fcfb3336a (diff)
merge of '8c0eb673de0b4022949225ca080e2dd264461926'
and 'a536e1f1c106f600dacb9b7c677edf69297378fb'
Diffstat (limited to 'packages/gpm/gpm_1.20.1.bb')
-rw-r--r--packages/gpm/gpm_1.20.1.bb31
1 files changed, 11 insertions, 20 deletions
diff --git a/packages/gpm/gpm_1.20.1.bb b/packages/gpm/gpm_1.20.1.bb
index 5623ebbf16..c017cafc9a 100644
--- a/packages/gpm/gpm_1.20.1.bb
+++ b/packages/gpm/gpm_1.20.1.bb
@@ -1,21 +1,25 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-DEPENDS = "ncurses"
DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
for the console and xterm, with sample clients included \
(emacs, etc)."
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "ncurses"
-PR="r1"
-PARALLEL_MAKE=""
+PR = "r2"
+PARALLEL_MAKE = ""
SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
file://no-docs.patch;patch=1 \
file://init"
-inherit autotools
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "gpm"
+INITSCRIPT_PARAMS = "defaults"
export LIBS = "-lm"
+
do_configure_prepend () {
cp aclocal.m4 acinclude.m4
}
@@ -29,18 +33,5 @@ do_install () {
oe_runmake 'ROOT=${D}' install
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
-}
-
-pkg_postinst () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm defaults
-}
-
-pkg_prerm () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm remove
+ cd ${D}${libdir} && ln -sf libgpm.so.1.19.0 libgpm.so.1
}