summaryrefslogtreecommitdiff
path: root/packages/gpe-bootsplash/gpe-bootsplash_svn.bb
diff options
context:
space:
mode:
authorPhilippe De Swert <philippedeswert@scarlet.be>2007-04-08 10:52:00 +0000
committerPhilippe De Swert <philippedeswert@scarlet.be>2007-04-08 10:52:00 +0000
commit1fdf9fe3c7fc8a1e2b00bd41c1992649c0f3b831 (patch)
tree775db414c4843953b87f479e4d078c73ccec90f4 /packages/gpe-bootsplash/gpe-bootsplash_svn.bb
parent5e75001f1c266439ce726d9b748a46b8b13107ec (diff)
gpe-bootsplash: adding new svn recipe
packages/gpe-bootsplash/gpe-bootsplash_svn.bb * new svn recipe for gpe-bootsplash packages/gpe-bootsplash/files/svn-build.patch * patch needed to build gpe-bootsplash-svn
Diffstat (limited to 'packages/gpe-bootsplash/gpe-bootsplash_svn.bb')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash_svn.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash_svn.bb b/packages/gpe-bootsplash/gpe-bootsplash_svn.bb
new file mode 100644
index 0000000000..df6d5da0c1
--- /dev/null
+++ b/packages/gpe-bootsplash/gpe-bootsplash_svn.bb
@@ -0,0 +1,36 @@
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libsvg-cairo"
+PR = "r0"
+PV = "1.15+svn-${SRCDATE}"
+
+inherit autotools
+
+SRC_URI += "${GPE_SVN} \
+ file://splash-p.svg \
+ file://splash-l.svg \
+ file://init.patch;patch=1 \
+ file://svn-build.patch;patch=1"
+
+S = "${WORKDIR}/${PN}"
+
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-gpe-portrait.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-gpe-landscape.svg
+ mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
+}
+
+FILES_${PN} += "${datadir}/gpe"
+
+pkg_postinst() {
+ update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg 10
+ update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg 10
+}
+pkg_postrm() {
+ update-alternatives --remove bootsplash-l /usr/share/gpe/splash-gpe-landscape.svg
+ update-alternatives --remove bootsplash-p /usr/share/gpe/splash-gpe-portrait.svg
+}
+
+DEFAULT_PREFERENCE = "-1"