summaryrefslogtreecommitdiff
path: root/packages/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-10-10 21:35:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-10 21:35:27 +0000
commitf8055b256eb749bf4216d0d8a6268c63758309dd (patch)
treed6d7547b610b84529e34d01838870a89d9bd9ff9 /packages/gnome
parent1e871e2689ece1b8d16815f97171b9cb612705ba (diff)
goffice: add 0.1.0
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/goffice_0.1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gnome/goffice_0.1.0.bb b/packages/gnome/goffice_0.1.0.bb
new file mode 100644
index 0000000000..db26a617a5
--- /dev/null
+++ b/packages/gnome/goffice_0.1.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+PR="r0"
+
+DEPENDS="glib-2.0 gtk+ pango libgnomeprint libgsf libglade libxml2 libart-lgpl"
+
+inherit gnome pkgconfig
+
+
+
+do_stage() {
+ gnome_stage_includes
+ oe_libinstall -so -C goffice libgoffice-1 ${STAGING_LIBDIR}
+}
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+