summaryrefslogtreecommitdiff
path: root/packages/gnome/gnome-vfs_2.6.0.bb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2005-04-16 08:21:34 +0000
committerPhil Blundell <philb@gnu.org>2005-04-16 08:21:34 +0000
commit9ef4139d17dc7ffa6e51224196fadcdbdc6737ac (patch)
tree5901bf29463848c7d969e8f0dcae6d1f6f64e7a2 /packages/gnome/gnome-vfs_2.6.0.bb
parentef9024025d446763888bc4007f719a1e6b186f6c (diff)
no need to set SECTION here since gnome.bbclass does it
BKrev: 4260cb0epSE90Xbe29uxrckA0YX8KA
Diffstat (limited to 'packages/gnome/gnome-vfs_2.6.0.bb')
-rw-r--r--packages/gnome/gnome-vfs_2.6.0.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/packages/gnome/gnome-vfs_2.6.0.bb b/packages/gnome/gnome-vfs_2.6.0.bb
index e69de29bb2..a048cdd172 100644
--- a/packages/gnome/gnome-vfs_2.6.0.bb
+++ b/packages/gnome/gnome-vfs_2.6.0.bb
@@ -0,0 +1,75 @@
+LICENSE = GPL
+PR = "r3"
+
+inherit gnome
+
+DEPENDS = "libxml2 gconf libbonobo bzip2 gnome-mime-data orbit2 zlib samba"
+
+SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1"
+
+ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
+
+FILES_${PN} += " ${libdir}/gnome-vfs-2.0/modules/*.so ${libdir}/bonobo/servers ${libdir}/bonobo/monikers/*.so ${libdir}/vfs"
+FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/modules/*.a ${libdir}/gnome-vfs-2.0/modules/*.la ${libdir}/gnome-vfs-2.0/include ${libdir}/bonobo/monikers/*.a ${libdir}/bonobo/monikers/*.la"
+FILES_${PN}-doc += " ${datadir}/gtk-doc"
+
+GNOME_VFS_HEADERS = " \
+gnome-vfs-utils.h \
+gnome-vfs-application-registry.h \
+gnome-vfs-async-ops.h \
+gnome-vfs-ops.h \
+gnome-vfs-uri.h \
+gnome-vfs-standard-callbacks.h \
+gnome-vfs-module-callback.h \
+gnome-vfs-context.h \
+gnome-vfs-file-info.h \
+gnome-vfs-directory.h \
+gnome-vfs-mime-monitor.h \
+gnome-vfs-mime-handlers.h \
+gnome-vfs-result.h \
+gnome-vfs-job-limit.h \
+gnome-vfs-file-size.h \
+gnome-vfs-mime-utils.h \
+gnome-vfs-find-directory.h \
+gnome-vfs-init.h \
+gnome-vfs-handle.h \
+gnome-vfs.h \
+gnome-vfs-cancellation.h \
+gnome-vfs-xfer.h \
+gnome-vfs-monitor.h \
+gnome-vfs-types.h \
+gnome-vfs-volume-monitor.h \
+gnome-vfs-drive.h \
+gnome-vfs-volume.h \
+gnome-vfs-enum-types.h"
+
+GNOME_VFS_MODULE_HEADERS = " \
+gnome-vfs-mime-info.h \
+gnome-vfs-transform.h \
+gnome-vfs-ssl.h \
+gnome-vfs-inet-connection.h \
+gnome-vfs-socket.h \
+gnome-vfs-parse-ls.h \
+gnome-vfs-method.h \
+gnome-vfs-cancellable-ops.h \
+gnome-vfs-module.h \
+gnome-vfs-module-shared.h \
+gnome-vfs-module-callback-module-api.h \
+gnome-vfs-mime.h \
+gnome-vfs-socket-buffer.h"
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ oe_libinstall -so -C libgnomevfs libgnomevfs-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs
+ for i in ${GNOME_VFS_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs/; done
+ install -d ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs
+ for i in ${GNOME_VFS_MODULE_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs/; done
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}