summaryrefslogtreecommitdiff
path: root/packages/git/git_1.5.2.3.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-08-03 20:44:20 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-08-03 20:44:20 +0000
commitf68a0b07dbfc2335454d3025e6261f32b2cffa3a (patch)
treeff3fd0a092a49b2c9c9f7abc005964075ed6061d /packages/git/git_1.5.2.3.bb
parent53c20a77542d9dd39cbecb6aeeb0144bc3ef49fd (diff)
git: fix building of git 1.5.2.3
* remove git.inc because 2 files are enough * let git-native require git * override RDEPENDS in git-native * switch to autotools * add files/autotools.patch so we can crosscompile * adding expat and zlib to the DEPENDS
Diffstat (limited to 'packages/git/git_1.5.2.3.bb')
-rw-r--r--packages/git/git_1.5.2.3.bb21
1 files changed, 18 insertions, 3 deletions
diff --git a/packages/git/git_1.5.2.3.bb b/packages/git/git_1.5.2.3.bb
index e6a1117316..f70d840c4c 100644
--- a/packages/git/git_1.5.2.3.bb
+++ b/packages/git/git_1.5.2.3.bb
@@ -1,11 +1,26 @@
-require git.inc
-DEPENDS = "openssl curl"
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR="r3"
+
+inherit autotools
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/git-${PV}"
+
+DEPENDS = "openssl curl zlib expat"
RDEPENDS = "perl perl-module-file-path cpio findutils sed"
-PR="r2"
+EXTRA_OEMAKE = "NO_TCLTK=1 LDFLAGS=${LDFLAGS}"
do_install() {
oe_runmake install DESTDIR="${D}" bindir="${bindir}" \
template_dir="${datadir}/git-core/templates" \
GIT_PYTHON_DIR="${datadir}/git-core/python"
}
+
+FILES_${PN} += "${datadir}/git-core"
+