summaryrefslogtreecommitdiff
path: root/packages/gdb/gdb-cross_6.6.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-04 11:22:16 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-04 11:22:16 +0000
commit4b7e6a49215b00d0cfa9a0fde3808f032a9599e5 (patch)
treef2e294728789ab01a7a89fa06b6c67c5464ceab0 /packages/gdb/gdb-cross_6.6.bb
parent4601ad28765bf7ef207974f9ad7fc209d3745088 (diff)
parent8f19556367701b3a3fa50802903d0d67997407b7 (diff)
merge of '274cb1a3f97188420857e4b0650a1ace718148a6'
and '8091ca9b08503f4700e05ee8973cec755727ed4a'
Diffstat (limited to 'packages/gdb/gdb-cross_6.6.bb')
-rw-r--r--packages/gdb/gdb-cross_6.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/gdb/gdb-cross_6.6.bb b/packages/gdb/gdb-cross_6.6.bb
new file mode 100644
index 0000000000..32076b529e
--- /dev/null
+++ b/packages/gdb/gdb-cross_6.6.bb
@@ -0,0 +1,35 @@
+LICENSE = "GPL"
+DESCRIPTION = "gdb - GNU debugger"
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "ncurses-native"
+
+inherit autotools sdk
+
+S = "${WORKDIR}/gdb-${PV}"
+SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
+ file://sim-install.patch;patch=1"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
+
+export CC_FOR_BUILD = "${BUILD_CC}"
+export CXX_FOR_BUILD = "${BUILD_CXX}"
+export CPP_FOR_BUILD = "${BUILD_CPP}"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
+export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
+export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
+
+EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
+
+EXTRA_OECONF = "--with-curses --with-readline"
+
+do_configure () {
+# override this function to avoid the autoconf/automake/aclocal/autoheader
+# calls for now
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ :
+}