summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-31 12:05:11 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-31 12:05:11 +0000
commitea0f18cab27893944c5a3c62a709fe42286a5c26 (patch)
tree54f69087b9f70773f61f892d40ca4a67001410b0 /packages/gcc
parenta324c95af6708ce6413c5b481b085ce7f1553a73 (diff)
gcc-cross-initial: add 4.1.2
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-cross-initial_4.1.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross-initial_4.1.2.bb b/packages/gcc/gcc-cross-initial_4.1.2.bb
new file mode 100644
index 0000000000..1e23ef9330
--- /dev/null
+++ b/packages/gcc/gcc-cross-initial_4.1.2.bb
@@ -0,0 +1,30 @@
+require gcc-cross_${PV}.bb
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils"
+DEPENDS += "${@['virtual/${TARGET_PREFIX}libc-initial',''][bb.data.getVar('TARGET_ARCH', d, 1) in ['arm', 'armeb', 'mips', 'mipsel']]}"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
+PACKAGES = ""
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
+ --with-newlib \
+ --disable-shared \
+ --disable-threads \
+ --disable-multilib \
+ --disable-__cxa_atexit \
+ --disable-libmudflap \
+ --disable-libssp \
+ --enable-languages=c \
+ --enable-target-optspace \
+ --program-prefix=${TARGET_PREFIX} \
+ ${@get_gcc_fpu_setting(bb, d)}"
+
+do_stage_prepend () {
+ mkdir -p ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}
+ ln -sf libgcc.a ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/libgcc_eh.a
+}
+
+# Override the method from gcc-cross so we don't try to install libgcc
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}